I've used Linux for a long time, but never really needed to get into hardware and drivers and all that. Now that I'm trying to install a Wireless LAN USB adapter (Belkin F7D4101), I'm finding the Googling and Linux forums to be... daunting.

Surely there's a simple procedure one can follow to connect to a wireless network in Linux? Contrary to what The Internets seem to assume, I don't use Ubuntu or any kind of X. I'm on Slackware (12, I think... It's been a while since I installed it) with kernel and it's all command-line (that machine doesn't even have a monitor on it).

Keeping in mind that I don't know much about drivers in Linux, couldn't tell you how to use modprobe for anything, can barely navigate my way through finding what hardware is recognized, etc... Can anybody help with a simple guide for setting this up? I remember colleagues having these same problems with 802.11B PCMCIA cars 10 years ago. Have things not improved since then?

All I know so far is:

  • My installation was a "full" from the Slackware DVD.
  • The USB bus sees it:
    > cat /proc/bus/usb/devices
    T:  Bus=01 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#=  2 Spd=480 MxCh= 0
    D:  Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=050d ProdID=615a Rev= 0.01
    S:  Manufacturer=Belkin Wireless Networks
    S:  Product=Play Wireless USB Adapter
    S:  SerialNumber=0
    C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=200mA
    I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=ff Driver=(none)
    E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=1ms
    E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
  • lsusb sees it:
    > lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 050d:615a Belkin Components 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  • iwconfig doesn't see it:
    > iwconfig
    lo        no wireless extensions.

    eth0      no wireless extensions.
  • ifconfig doesn't see it:
    > ifconfig
    eth0      Link encap:Ethernet  HWaddr 90:fb:a6:32:a3:38  
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::92fb:a6ff:fe32:a338/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2169 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1153 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:229315 (223.9 KiB)  TX bytes:249847 (243.9 KiB)
              Interrupt:27 Base address:0xc000 

    lo        Link encap:Local Loopback  
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:82 errors:0 dropped:0 overruns:0 frame:0
              TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:4340 (4.2 KiB)  TX bytes:4340 (4.2 KiB)

I'm found a wiki page for configuring the network itself once the adapter is up and running, and all of that seems to make sense. But everything I find for actually getting the adapter up and running isn't helping so far. It's all forum posts from years ago or very distro-specific or assuming something like "it's easy... all you need to do is follow these vague steps which assume you've done this before and know what you're doing already."

Can anybody help?

  • Slackware hasn't improved much in that time. There's a reason the documentation you can find talks about Ubuntu, Fedora, and other modern systems with hardware autoconfiguration; Slackware expects you to do it the hard way.
    – geekosaur
    Mar 5, 2011 at 17:38

1 Answer 1


Snark aside, this post is the best I can find. While it's on an Ubuntu forum, the basics of ndiswrapper are the same everywhere: install the Windows driver somewhere, copy over the driver files, and run ndiswrapper on them.

  • Well, I'm used to the snark :) The ndiswrapper tool seems to be working so far. I ran it on the XP driver and it now tells me (with ndiswrapper -l) that the driver is loaded and the device is present, which is a good sign. However, as I understand it I now need to modprobe ndiswrapper which tells me that it can't find ndiswrapper. I've tried depmod -a and rebooting, but no luck.
    – David
    Mar 5, 2011 at 18:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .