I had Virtual Box 3.2 working fine, emulating 32-bit Windows XP in a 64-bit Windows 7 host. Then I upgraded to VirtualBox 4.0.4, and everything seemed to work (after I installed a couple of things -- USB2.0 support, Guest Additions).
Then I restored a snapshot that was taken under version 3.2, and now I've lost everything. I get the error message:

The selected virtual machine is *inaccessible*. Please inspect the error message shown
below and press the **Refresh** button if you want to repeat the accessibility check:

Could not find an open hard disk with UUID {b0e666ef-1041-415a-8329-876b337e1958}.
Result Code: 
IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}

I tried creating a new virtual machine from the vdi file, but it locks up when loading WINDOWS\System32\DRIVERS\lfsfilt.sys. I tried re-installing version 3.2, but I get exactly the same problems.

I have a VirtualBox.xml file in my .VirtualBox directory, and various files (Virtual Dell.xml, Virtual Dell.xml-prev etc.) in .VirtualBox\Machines\Virtual Dell.

Help please! How do I get my virtual machine back?

  • You might try booting the VM from a windows CD or a rescue disk ISO image. It may just need chkdsk running or a file deleting/adding.
    – Chris
    Mar 5 '11 at 23:21

I had the same issue, but in slightly different circumstances.

I am running ubuntu 10.10 with vbox 4.0.4, installed directly (not upgraded)

I was able to find the VDI file by its UUID, so I knew it existed.

I fixed the problem by editing the .vbox file for the VM and re-attaching the hard disk.

I have posted this solution to the virtualbox.org forums as well.

For these instructions assume VM name is win7

  1. Make a backup of the win7.vbox file
  2. Edit the win7.vbox file
  3. Find the "" line that references the UUID for the "missing" disk. It should be inside of an section inside of a section.
  4. Remove the entire section. (You made a backup right?)
  5. Save the file.
  6. Go back to the VBOX GUI and refresh the VM. It should no longer complain about the hard drive.
  7. Edit the settings for the VM (This is what you couldn't do before), go to the Storage section, find the hard disk controller.
  8. Add a disk. VBOX will ask if you want to add a new or existing disk. Select existing disk.
  9. Find and select the disk with the original UUID that was reported "missing"

I hope this works for you even though you are in a slightly different circumstance (upgrade to 4.0.4 rather than install of 4.0.4).


If you wish to revert to a snapshot that didn't have the Guest additions, then you might need to remove those features before things will work again. You see, Windows might be having trouble with the changes to the hardware environment it's detecting (which is your virtual machine with the guest additions).

Can you get your virtualized Windows installation to boot into Safe Mode?

  • No I can't, Randolf - it locks up when loading lfsfilt.sys. (The previous version had Guest additions too, but I had to upgrade them for the new VirtualBox.)
    – ttt
    Mar 5 '11 at 21:14

in Virtual Media Manager, is the XP VDI disk attached to the virtual machine? If it is not then open settings for the VM and add the VDI in the Storage tab

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.