9

I've been using kwrite for a long time and love the way I can turn on/off line wrapping easily. Now I'm running Ubuntu with GNOME, trying to avoid any KDE at all on this particular machine. Gedit seems to always wrap lines with no way to turn it off. Am I missing some well-hidden option?

13

Edit > Preferences > View Tab > Text Wrapping options right there, front and center. Not "well hidden" by any means.

  • 3
    That seems a bit deep for turning on and off routinely. Kwrite has it immediately available in the menu bar's View. – DarenW Mar 6 '11 at 4:21
  • It's be nice if there were a hotkey for that. – DarenW Mar 6 '11 at 15:33
  • 1
    Get the source code and make the change yourself. Great opportunity to learn. :) – Joshua Mar 7 '11 at 5:34
4

As of gedit 10.4, there is no preferences dialog anymore. Some of the options are now in the status bar, but not word-wrapping.

You can turn word wrapping off by tweaking the GSettings settings. To do so, run the following command in your terminal:

gsettings set org.gnome.gedit.preferences.editor wrap-mode none

Besides none, you can also turn it back on with either word, char, or word-char word wrapping.

  • Is there a shortcut for enabling and disabling wrapping? – htellez Dec 28 '15 at 22:25
  • 3
    @htellez my current gedit (3.16.2) has a "Text wrapping" option if you click on the right part of your status bar (where Ln, Col. numbers are) – istepaniuk Jan 8 '16 at 13:27
  • Thanks @istepaniuk. I don't see such an option and I'm using 3.10.4. Could you share a screenshot? I would prefer a 'no mouse' way to do it, is always faster using keyboard shortcuts than using the mouse and I have been wrapping/unwrapping a lot lately. – htellez Jan 8 '16 at 19:26
  • Sorry I didn't noticed your gedit version was higher than mine until now. Anyway, do you know if there is a way to make a keyboard shortcut MACRO with it? – htellez Jan 11 '16 at 21:27
  • 1
    in 3.14.3 there also is a "warp" checkbook if you click the "Ln .., Cl .." bar at the bottom, thank you @istepaniuk – MInner Oct 5 '16 at 14:55
0

When running as root there is no Preferences menu

By default when you run gedit as root there is no top level menu. The only alternative (in my version 3.18.3) is to click on the last drop down menu on the lower right corner:

gedit text wrap.png

Notice I have "unchecked" text wrap option to make /var/log/syslog file more readable for debugging output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.