I don't seem to be able to copy and paste any more. Not sure what I did to cause it.

I've tried doing it in several programs, including notepad.

Is there a quick and simple fix for this problem, that doesn't involve restarting my pc?

up vote 34 down vote accepted

Found a solution here

Run the following: cmd /c "echo off | clip"

You can even make it into a desktop shortcut if the problem keeps happening.

  • how did that make your clipboard work? – barlop Mar 7 '11 at 16:35
  • 3
    This pushes the last app out of the clipboard. May cause a memory leak but as OP noticed, it give you the control back. – Aaron Digulla Apr 12 '11 at 7:20
  • 8
    This is not working for me: I got an error "ERROR: Access is denied."; The clipboard stopped functioning after I put a big data inside it (around 128mb). – рüффп Jun 22 '12 at 10:12
  • 7
    Can't copy paste that code.. :-) It worked, thank you! – Geo Apr 3 '13 at 16:54
  • Didn't work for me ! Any other suggestions please – The Beast Jan 8 at 12:17

For me the problem was happening only when there was a RDP session open to another machine. After closing RDC, clipboard started working again.

  • 1
    You mean RDP? That's what was doing it to my clipboard. Once I closed my RDP session, clipboard came back. – davej Sep 11 '13 at 13:43
  • 1
    I meant using RDC (Remote Desktop Connection client), which uses RDP (Remote Desktop Protocol) – Oleg D. Nov 20 '13 at 22:30
  • I had no RDP sessions open, but I started and then closed the client and this fixed it. – Stoinov May 22 at 14:06

None of the above solutions worked for me. This one however did: http://sys-talk.blogspot.com/2009/04/clip-board-not-working-in-windows-xp.html (I am pasting the urls from the browser:) ) Generally, this tool locates an app that is holding the clipboard. For me, it was Xserver. For you, who knows.

  • For me it was rdpclip.exe (I was connecting from ubuntu 16.04 to the windows PC) – ndemou Mar 26 at 14:15

If this is over Remote Desktop (RDP) then ensure that rdpclip.exe is running on the remote machine. You can start it using Win+R and then rdpclip

  • 3
    for me killing rdpclip with taskmgr.exe first, then starting it... finally did it! – eddygeek Aug 7 '17 at 20:37

There's probably an app that's "locked" the clipboard. Try and work out what app has done that and close it.

In my case it was a hung Greenshot.

Simple fix: Try to restart your PC. Doesn't get more simple than that.

As for the possible reasons:

  • Bug in an application: It acquired the clipboard and never freed it
  • Windows ran out of memory a while ago and is now confused. It'll probably crash soon (blue screen).
  • Virus
  • 2
    Thanks. I was hoping for a method that doesn't involve a restart. – Urbycoz Mar 7 '11 at 14:04
  • 1
    Use the task manager to kill the process that has hung the clipboard. This will likely take an educated guess (you see an app there that you have already closed, yet it still lingers), a lucky guess (random roulette), or a reboot. The random/lucky guesses should be marked on a scrap of paper for next time, so you can make better guesses. – Chris Thornton Apr 9 '11 at 19:55

Windows Notepad may be unable to handle excessively large content, or content with special characters. Although Notepad will generally strip out unsupported character set encodings or control characters, it is first and foremost a simple text file editor.

In my case, I had pasted a large amount of code from my development environment, which apparently overwhelmed Notepad. Even running the command to manually clear the clipboard failed. [cmd /c "echo off | clip"]

As per Mathew Lock's suggestion of an Application that had locked the Windows clipboard, I narrowed down the culprit to that of Notepad. Immediately upon terminating my NOTEPAD process, the lock on Windows Clipboard was freed.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.