I don't seem to be able to copy and paste any more. Not sure what I did to cause it.

I've tried doing it in several programs, including notepad.

Is there a quick and simple fix for this problem, that doesn't involve restarting my pc?


8 Answers 8


Found a solution here

Run the following: cmd /c "echo off | clip"

You can even make it into a desktop shortcut if the problem keeps happening.

  • how did that make your clipboard work?
    – barlop
    Commented Mar 7, 2011 at 16:35
  • 3
    This pushes the last app out of the clipboard. May cause a memory leak but as OP noticed, it give you the control back. Commented Apr 12, 2011 at 7:20
  • 10
    This is not working for me: I got an error "ERROR: Access is denied."; The clipboard stopped functioning after I put a big data inside it (around 128mb).
    – рüффп
    Commented Jun 22, 2012 at 10:12
  • 7
    Can't copy paste that code.. :-) It worked, thank you!
    – Geo
    Commented Apr 3, 2013 at 16:54
  • Didn't work for me ! Any other suggestions please
    – The Beast
    Commented Jan 8, 2018 at 12:17

For me the problem was happening only when there was a RDP session open to another machine. After closing RDC, clipboard started working again.

  • 1
    You mean RDP? That's what was doing it to my clipboard. Once I closed my RDP session, clipboard came back.
    – davej
    Commented Sep 11, 2013 at 13:43
  • 1
    I meant using RDC (Remote Desktop Connection client), which uses RDP (Remote Desktop Protocol)
    – Oleg D.
    Commented Nov 20, 2013 at 22:30
  • I had no RDP sessions open, but I started and then closed the client and this fixed it.
    – Stoinov
    Commented May 22, 2018 at 14:06
  • You're kidding me, this was it. I had 3 RDP sessions open. After closing them all, I'm operational again. Commented Jan 29, 2021 at 21:00

There's probably an app that's "locked" the clipboard. Try and work out what app has done that and close it.

In my case it was a hung Greenshot.


If this is over Remote Desktop (RDP) then ensure that rdpclip.exe is running on the remote machine. You can start it using Win+R and then rdpclip

  • 3
    for me killing rdpclip with taskmgr.exe first, then starting it... finally did it!
    – eddygeek
    Commented Aug 7, 2017 at 20:37

None of the above solutions worked for me. This one however did: http://sys-talk.blogspot.com/2009/04/clip-board-not-working-in-windows-xp.html (I am pasting the urls from the browser:) ) Generally, this tool locates an app that is holding the clipboard. For me, it was Xserver. For you, who knows.

  • For me it was rdpclip.exe (I was connecting from ubuntu 16.04 to the windows PC)
    – ndemou
    Commented Mar 26, 2018 at 14:15

Simple fix: Try to restart your PC. Doesn't get more simple than that.

As for the possible reasons:

  • Bug in an application: It acquired the clipboard and never freed it
  • Windows ran out of memory a while ago and is now confused. It'll probably crash soon (blue screen).
  • Virus
  • 2
    Thanks. I was hoping for a method that doesn't involve a restart.
    – Urbycoz
    Commented Mar 7, 2011 at 14:04
  • 1
    Use the task manager to kill the process that has hung the clipboard. This will likely take an educated guess (you see an app there that you have already closed, yet it still lingers), a lucky guess (random roulette), or a reboot. The random/lucky guesses should be marked on a scrap of paper for next time, so you can make better guesses. Commented Apr 9, 2011 at 19:55

Windows Notepad may be unable to handle excessively large content, or content with special characters. Although Notepad will generally strip out unsupported character set encodings or control characters, it is first and foremost a simple text file editor.

In my case, I had pasted a large amount of code from my development environment, which apparently overwhelmed Notepad. Even running the command to manually clear the clipboard failed. [cmd /c "echo off | clip"]

As per Mathew Lock's suggestion of an Application that had locked the Windows clipboard, I narrowed down the culprit to that of Notepad. Immediately upon terminating my NOTEPAD process, the lock on Windows Clipboard was freed.

  • This can also occur in applications with tabs where a specific tab is the source of the excessively large content. Closing the source tab freed things up for me - without having to close the whole application. (Sql Server Management Studio in my case)
    – Simon
    Commented Oct 26, 2018 at 9:20

Kill "explorer.exe" process, it was the source of my problem, when I killed itm, copy/paste started working again. Note that you apps bar will disapper, and you will need to execute explorer.exe from taskmgr, New task.

Other option is from free Systernals app "process explorer", selected explorer.exe , then "Properties", "Threads" tab, select "Ole32.dll" and then click "kill".

After killing the thread i was not able to reproduce again the mistake.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .