66

I'm using Outlook Web Access to read my email. When I receive a meeting notice and acknowledge it, Outlook adds it to my calendar then deletes the email. Is there a way to disable Outlook automatically deleting the meeting email?

There doesn't seem to be any way to configure this in Options - Messaging and Options - Calendar. Note that I'm using Outlook Web Access and not the desktop client.

From the copyright date this appears to be Outlook 2007.

Follow-up: Based on edusysadmin's comment I logged-in using IE8, which exposed a setting not available in Firefox - "Move out-of-date meeting requests and responses to the Deleted Items folder". However unchecking this box doesn't seem to impact the auto-delete behavior.

Follow-up 2: Keep in mind I am using Outlook Web Access via a web browser. I do not have the thick client Outlook installed.

5
  • 2
    The available options in Outlook Web Access have nothing to do with the Outlook client, but the version of Exchange implemented. Depending on the Exchange version it may also depend on what browser you're using too as some browsers cannot see all the option menus. Mar 7, 2011 at 19:36
  • 2
    While I don't have an answer for you, I'm intrigued to know why you want to do this. Are you aware that if you want to change your mind (for example decline a meeting you already accepted) you can do this by opening the meeting item in your calendar and using the options there to respond, just as with the original request? Of course, this does not allow you to accept something that was declined, since that won't be in your calendar.
    – AdamV
    Mar 21, 2011 at 10:15
  • 7
    @AdamV, the problem is then I have to manually search through my calendar just to find it. And like you said, if it's declined then it's no longer there. The auto-delete feature is just lame. And not exposing the configuration for it in OWA is even lamer.
    – Wavy Crab
    Mar 29, 2011 at 0:00
  • 2
    I wonder if in OWA one can create a rule for "Check messages when they arrive", select the condition "is a meeting invitation or update", and as action move it to a new folder. If this works, the downside is needing to access this folder to respond to the request.
    – harrymc
    Apr 13, 2016 at 17:30
  • 1
    Possible duplicate of Keep Outlook Invitations in Inbox
    – Gaff
    Nov 21, 2016 at 22:03

6 Answers 6

55
+50

In Outlook 2013 and 2016 (Office 365), this is under Options -> Mail -> under "Send messages":

Delete meeting requests and notifications from Inbox after responding.

It seems trivial but takes long time to find it.

Please see the screenshot:

enter image description here

4
  • 1
    Perfect for 2013!
    – thomasa88
    Feb 23, 2015 at 9:09
  • 28
    What a stupid feature. When I accept an invitation, I usually want to re-read the details. Instead Outlook completely deletes it from my inbox. Apr 13, 2016 at 15:14
  • This answer works in most cases (thanks!), but I found that the invitation mail is still deleted from Inbox when I send an invitation and add myself in CC. Not sure if there's a different setting for this.
    – oliver
    Apr 23, 2019 at 13:00
  • 4
    Question asks about OWA but this is for the desktop client. Oct 8, 2019 at 16:14
18

In Outlook Web Access(OWA), Under

Options -> Calendar Options

Uncheck the following checkboxes:

  • Automatically place new meeting requests on my calendar, marked Tentative
  • Move out-of-date meeting requests and responses to the Deleted Items folder
8
  • 10
    Thanks. This led me to the correct setting. In newer versions it is Options->See All Options->Settings->Calendar->Delete meeting requests and responses that have been updated
    – tstaylor7
    Nov 11, 2014 at 15:16
  • 2
    @tstaylor7 when you say newer versions, can you provide a range of versions? If you can tell me that I will update my answer.
    – Ryan Gates
    Nov 11, 2014 at 15:41
  • 1
    Help->About gives me Version: 14.3.210.2 and Client Access server version: 14.3.123.0. I'm not sure which is the relevant one or when the change was made. I'm just a lowly end user, in this case.
    – tstaylor7
    Nov 11, 2014 at 22:33
  • 1
    @tstaylor7 Is that 2007, 2010, 2013?
    – Ryan Gates
    Nov 12, 2014 at 19:15
  • 1
    According to this page, it is Update Rollup 7 for Exchange Server 2010 SP3.
    – tstaylor7
    Nov 12, 2014 at 20:25
14

In Outlook 2007 (not sure about other versions), go to

Tools -> Options -> E-mail Options -> Advanced E-mail Options

Uncheck

"Delete meeting request from Inbox when responding"

(3rd from the bottom)

5
  • 1
    I can't find that option in Outlook Web Access (even when using IE8).
    – Wavy Crab
    Mar 15, 2011 at 17:28
  • 1
    Ah, it seems it is only available in the Outlook desktop app. Perhaps if you configure it using the desktop client the setting will propagate to the OWA? Mar 17, 2011 at 10:55
  • 2
    Thanks but I don't have the Desktop app. I'm on a Mac and Outlook isn't free. $280 (for Office) isn't worth it to just to toggle this setting.
    – Wavy Crab
    May 17, 2011 at 20:39
  • 1
    visual answer here
    – phuclv
    Jul 25, 2014 at 5:48
  • 1
    Should specify what version of Outlook (2007?) these instructions were for, as this no longer applies to Outlook 2013.
    – CragMonkey
    Jul 9, 2015 at 19:39
2

An update for more current OWA (Outlook Web Access). Go to

Settings -> Calendar -> Events and invitations

and deselect

  • "Delete Invitations and responses that have been updated" and
  • "Delete notifications about forwarded events".
1
  • 7
    These are deselected, but it still deleted the emails for me.
    – gerrit
    Jun 10, 2020 at 15:35
1

You can do this from OWA.

Click "Options" in the upper right corner. Click "Calendar Options" in the left scrolling list. Uncheck "Move out-of-date meeting requests and responses to the Deleted Items folder" in the "Automatic Calendar Processing" section of the options.

Hope that works for you.

(I'm using OWA 8.4.106.1 with IE8).

3
  • 1
    Sorry, just noticed your addendum that this didn't work for you. I'll assume that you saved your change to the prefs and that it took. Is it possible that a mobile device is syncing with your account and also doing the delete?
    – CCrawford
    Apr 12, 2011 at 19:59
  • 1
    There are no other clients synced with my account .I just verified and I do have "Move out-of-date meeting requests and responses to the Deleted Items folder" unselected. I accepted a meeting notice and the meeting email is still automatically deleted.
    – Wavy Crab
    Apr 13, 2011 at 1:20
  • 1
    All that does is automatically delete a meeting request if the time window has already passed.
    – KCotreau
    Jun 5, 2011 at 16:30
1

Also enable the following in the Mail section of the Outlook options:

Update tracking information, and then delete responses that don't contain comments

1
  • 1
    @JosephA, it wasn't just an image at the time you commented?
    – Arjan
    Mar 28, 2016 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.