15

This is driving me bonkers as I use both a mac and windows machine, on the mac to move the cursor through words I press OPTION+ARROW, on a PC it's CTRL+ARROW, I am not too worried about the reversed keys, but what is annoying is when I get to my windows computer and I accidentally press the WINDOWS key by mistake with an arrow key it docks the window to the side of the screen, which is quite troubling, I'd prefer it to do nothing as it did in XP and Vista, any ideas?

5

Microsoft has a little doohickie that will disable your Windows key for you here, or you can disable it yourself by modifying your registry:

  • Click Start, click Run, type regedt32, and then click OK.
  • On the Windows menu, click HKEY_LOCAL_ MACHINE on Local Machine.
  • Double-click the System\CurrentControlSet\Control folder, and then click the Keyboard Layout folder.
  • On the Edit menu, click Add Value, type in Scancode Map, click REG_BINARY as the Data Type, and then click OK.
  • Type 00000000000000000300000000005BE000005CE000000000 in the Data field, and then click OK.
  • Close Registry Editor and restart the computer.
| improve this answer | |
  • Fantastic goblinbox, I haven't restarted yet but it looks like disabling the windows key will do the perfect thing for me, I never used it, even for the start menu I have always pressed CTRL+ESC, thanks a billion :) – Brett Ryan Mar 8 '11 at 1:00
  • No kidding! It's a rare user who needs that Windows key, methinks. – goblinbox Mar 8 '11 at 1:13
  • 1
    This was BAD. Perhaps I typed in the binary number wrong (Windows 10 would not let me paste it in), but the end result after a reboot is my keyboard did not work. Tried both USB and PS2. Had to use on-screen keyboard to remove the registry value and get my keyboard working again. Be careful with this trick. – Gabe Halsmer Sep 9 '16 at 23:33
  • 2
    This is not an answer to the question. The question is not asking how to disable the Win key, it is asking how to disable the Win+Arrow keys. The user who needs that Win key is not rare at all. – Mike Nakis Dec 20 '18 at 10:13
15

There is an extremely simple answer to this question which I haven't seen described anywhere else.

To enable or disable the Win + arrow keys that move windows around (docking, maximizing, moving to other monitors, etc), go to the Ease of Access Center in the Control Panel:

Control Panel\Ease of Access\Ease of Access Center\Make it easier to focus on tasks

On this screen, the section "Make it easier to manage windows" has a checkbox for "Prevent windows from being automatically arranged when moved to the edge of the screen". Checking this box disables all the Win + arrow keys.

Ease of Access Dialog

| improve this answer | |
  • 5
    This worked for Win + (right, left), and is a great answer. But it doesn't work for Win + (up, down). Thanks tho'! – Pedro Nov 21 '18 at 19:01
  • @Pedro: It definitely does work for Win+up & Win+down - I just re-checked and it controls all the arrow keys. Perhaps you're having a different problem - post a new response with more details and maybe someone can figure out what's going on. – chasbas Nov 23 '18 at 13:16
  • I confirm that this solution works for all Win+Arrow keys. And this solution is the answer, because the question is not about disabling the Win key, (which is useful for other things,) it is specifically about disabling the Win+Arrow keys. Thanks @chasbas! – Mike Nakis Dec 20 '18 at 10:11
  • I can confirm that on Windows 10, this option only disables the Left and Right window snapping behaviour. It doesn't change the maximize/minimise shortcuts. – xerxesb Jul 18 '19 at 22:07
6

You can use AutoHotKey to disable any standard windows shortcut keys. This does not involve updating the registry. Simply download the standalone autohotkey program. Then create a file, say "DisableWinKeys.ahk" on Desktop. Open it in Notepad and write following in it:

#right::return ;This will disable the effect of Win + -> 
#left::return ;This will disable the effect of Win + <- 

Save the file and open it with ahk.exe from AutoHotKey folder. That's it. If you close the "H" icon from System Tray, it will enable the shortcuts again.

| improve this answer | |
  • Wow, that does sound neat. I've already tried the registry approach though this one does seem very handy indeed, especially for those who still want the windows key to open the start menu. – Brett Ryan Mar 8 '11 at 1:43
  • Thanks for sharing. For a version including the shift key and the up and down arrows see snipt.org/BDag6 – Felix Alcala Dec 19 '13 at 14:17
  • 1
    This didn't work for me, but two small modifications fixed it. Make the first line #right:return and the second #left::return. The + breaks the key mapping, apparently including the literal plus key in the hotkey definition. As for return, without that, control flow falls down into the following definition. An immediate return causes AHK to do nothing with the keystroke, as the OP wanted. – Warren Young Oct 16 '16 at 14:48
  • You still have the + signs in your script, which as I said caused problems here when I tried it. – Warren Young Jan 16 '17 at 23:05
  • @WarrenYoung The plus sign ("+") indicates "Shift" key. If you do not need shift key as part of the hotkey, you can remove it. Also, updated the script. Probably, the changes were not save the last time I edited it. – AshTee Feb 14 '17 at 17:36
0

For non-power-users, I have just answered a similar question.

Here: https://superuser.com/a/129205/134004

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.