I set up a DynDns account to point a domain to my dynamic IP server at home. From any "outside" network, the connection is working and pointing to my server. But when I point my browser to my URL (xxxx.dyndns.org) from within my LAN it goes to the login page of my ADSL modem.

What am I doing wrong?

  • I have exactly the same problem. I've managed to gain telnet access to my router, and can execute iptables commands, which I assume can solve the situation somehow (if only I knew).
    – aaaidan
    Mar 12, 2011 at 5:05

4 Answers 4


You're not doing anything wrong, this is exactly how DynDNS works. DynDNS is returning your public IP for your home internet connection, which the router responds on. Because you are inside the network, it is assuming you want to connect to the router itself and not the port forwarding rules because you are already behind the firewall. To be able to use your DynDNS URL inside your network, your router needs to support NAT reflection (or port reflection). This allows internal users to connect to your public IP and it reflects back to the right internal IP through the router's port forwarding rules.

If you don't have this, you will need to either run dual DNS, or use other methods such as overriding your hosts file when internal on the network.


If your router doesn't support NAT reflection you could use port forwarding, but this would largely depend on what you are hosting.

  • 1
    In my case, I have already set up port forwarding but it still doesn't work from inside the network... :(
    – aaaidan
    Mar 12, 2011 at 5:06
  • I'm hosting some test websites (running Wordpress), and I set up this dyndns account to be able to show my stuff to other people. They can access to the home page, but when they click on any link, they get an error (as the links are internal IPs from my LAN). As a solution I thought of using my dyndns address as a base URL for my developments, but then I just go to my router login (cf my initial question)
    – mike23
    Mar 17, 2011 at 20:33

You need NAT reflection. On my (Zyxel USG60W) router this feature is called NAT Loopback. It can be found on the NAT/Port forwarding page. First, I got a warning because I have set my external/original IP to any. Fixed it by setting it to the public address of my WAN1 port. You can get the address automatically by creating an address object and selecting interface IP and then choosing wan1.


I had the same problem. I've ended up installing dnsmasq on a machine in my lan and adding this line to dnsmasq.conf:


Then use that machine as dns server.

What this does is mapping the ddns domain name to the desired ip in my lan. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.