I have cookies enabled in my browser settings, but cookies are not functioning - in for example, trying to remain logged into websites (like Yahoo mail).

I usually run Firefox, but have noted that this problem exists no matter what browser I use. I will describe details on Firefox.

Firefox setting: In Tools->Options->Privacy, checked Accept cookies from sites and Accept third-party cookies, Keep until they Expire.

I've always remained logged into Yahoo mail and other sites and could even shut down my computer and reboot - remained logged in. Now that doesn't work. Right now, I'm testing my computer to see if it will work for a "virtual show": (http://robovirtualevents.com/) and it tests cookies, among other things. Their check says cookies are disabled.

Possible hints: I did something extra to clear the cache just before this problem appeared. I don't remember the details and it may have involved removing cookies (which I would have assumed would come back when I clicked to remain logged in again). I clear history when exiting and I also have my browser set to clear everything in the cache when it closes.

1 Answer 1


Some "internet security" suites such as McAfee or Norton have cookie-blocking modules built in to them and can as a result of some fault or update end up blocking all sites instead of specific ones.

Check whatever firewall or antivirus suite you are using to see if they are blocking cookies getting through to your browsers.

  • Windows Vista using Windows Firewall and Spybot Search & Destroy. In response to your suggestion, I tested by turning off the firewall, logging in with "remain logged in" feature checked and rebooting (more than once). No effect. Mar 8, 2011 at 16:31
  • Fair enough, I thought it might be a possibility it all. Is Spybot resident in your system tray? I can't remember if it had a cookie killer feature. It just seems weird that it affects all your browsers which is why I was looking more towards system wide tools than something Firefox related.
    – Mokubai
    Mar 8, 2011 at 17:28
  • I've never had a problem with Spybot and am not sure how to turn it off; but I tried disabling all the resident in browser stuff by unchecking it. Unchecked everything and tried that. No effect. Also, despite the fact that I'm sure I turned it off once, I discovered that Windows Defender was also running - so I turned that off and tried. No good; now for some reason Chrome was still logged in to Yahoo Mail (Good thing?) while neither Firefox nor IE will even start. Mar 8, 2011 at 17:36
  • Update: Rebooted and all browsers are running again. Original problem still not solved. Mar 8, 2011 at 18:24
  • Hmmm a long shot from computing.net/answers/windows-xp/… : "Have you checked what year is selected in the Date and Time of the control panel. If it is the wrong year, your cookies will not work."
    – Mokubai
    Mar 8, 2011 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .