I have Ubuntu 9.10. Headphones appear to work fine. External speakers - nothing. There are so many sound preferences I have no idea what or which combination.

Went to terminal and ran alsamixer which seems to recognize my sound card, though the driver is not listed in System > Administration > Hardware Drivers; the only driver listed is my graphics card.

I have tried several forums and it seems no one is interested in responding to sound issues.
Here's hoping it is different here.


Are your speakers active or passive?

If they are active then they'll need an external source of power. If they are passive then they'll take the power from the audio output, but that might not be enough to drive them.

Also (though this is a bit obvious) check that you've got the speakers plugged into the correct output of your sound card. Some have separate outputs for speakers & headphones etc.

  • Active (plugged in). Almost positive but tried all, nothing. Could my preferences be set up wrong, tho I have tried all combinations. Very frustrating. – Walter Mar 8 '11 at 15:33

Have you tried running alsamixer in a terminal? Alsamixer seems to be the most reliable for me at this point until updates come down....

so just open a terminal and digit


Alsamixer quickie tips: left - right to navigate up - down - change levels M - key - toggle mute/unmute B - key - balance channel pairs

Take care :)

Update kernel:

type in terminal: uname -r

Next find available kernel images typing in terminal:

sudo apt-cache search linux-image

Now install kernel by explicitly specifying version number typing in terminal:

sudo apt-get install linux-image-x.x.x-xx

  • Re: alsamixer. Master is at 100%, PCM is at 100% and mute is off. – Walter Mar 8 '11 at 15:27
  • Whoooops! Did you try updating kernel?! – Pitto Mar 8 '11 at 15:31
  • Now you have me. I am somewhat pc savvy but no geek. I have no idea how to do that, and is that the problem? – Walter Mar 8 '11 at 15:35
  • Appreciate your help Pitto. But could you be more specific. I typed in -r and it says command not found. Okay maybe I am not that savvy...lol – Walter Mar 8 '11 at 15:54
  • Oh no....have you abandoned me? – Walter Mar 8 '11 at 16:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.