I tried to install Windows 7 Service Pack 1 (64 bit) on my Dell notebook. Everything worked fine up to the first reboot after the installation. When booting, right before the Windows logo appears, a bluescreen with code STOP 0x0000007B occurs. Booting in safe mode is not possible, as it states a corrupt SP1 installation and wants to restore the system.

Restoring resulted in several system problems (.NET framework for example). So I decided to do a fresh install of Windows 7 and then install the SP1 directly before installing anything on the new install.

As you perhaps already guessed: it did not help a thing. Bluescreens on almost every boot attempt. I then found some articles which said, it may be a SATA driver problem and I switched from AHCI to IDE with no success.

What could be the problem? Any guesses and advices?

System: Dell Studio 1558 with Corsair SSD F240 drive and Windows 7 Home Premium 64bit

  • Did you successfully switch from AHCI to IDE before the install? AHCI needs either a fresh install or registry changes in order to properly work on Win7. – James Mertz Mar 9 '11 at 14:01
  • @KronoS - The registry change is trivial, thankfully, especially compared to the nightmare it was in XP; I've never had to do a clean install for this in Win7. – Shinrai Mar 9 '11 at 15:15
  • When I switched from IDE to AHCI there was an issue of my Win7 machine BSOD'ing. I assumed that vice versa was an issue as well. @Sinrai – James Mertz Mar 9 '11 at 15:34
  • @KronoS - I'd be interested to know what hardware you were running that on because I've never even once seen an issue enabling AHCI mode in Win7, and I've done it on tons of stuff. – Shinrai Mar 9 '11 at 23:33
  • @Shinrai It was a core i7 intel with 6 gb of ram. I was installing an SSD as well. Didn't boot when I changed the settings in the BIOS until I did the registry hack. – James Mertz Mar 10 '11 at 0:36

My first guess would be a corrupt device driver - maybe not something as drastic as a SATA driver, but it could be something you haven't thought of such as a webcam.

(e.g. I remember Windows XP SP1 failing because of my USB CD-RW Drive)

If you are not using the computer much at the moment because of this, as a test, I would recommend you reinstall Windows 7 and attempt to disable pretty much every piece of hardware you can from device manager before trying to load up SP1, then enable one by one and do a restart.

If this doesn't help, please let me know and I will try and help further.

  • This sounds like probably a SATA driver to me. :/ OP should do the restore (after going back into AHCI mode if that's where it was originally.) – Shinrai Mar 9 '11 at 15:16
  • 1
    @Shinrai - Not completely saying it isn't, but there isn't much variation as far as controller drivers go and I am sure that many more people would be screaming around the internet about this, which is why I think it is more likely to be an obscure device... but, without more information, can't rule anything out. – William Hilsum Mar 9 '11 at 15:52
  • Thanks for your answer. The strange thing is, there is a small chance that the system boots up successfully, but the next reboot attempt may or will fail again. I'm also pretty sure, it must be any device driver, but which one?! Have to try by disabling as much hardware as possible and reenable them if things still work. – Scoregraphic Mar 10 '11 at 7:57

It's worth trying the startup repair; whenever "inaccessible boot device" has reared its ugly head to me, that has fixed it in Vista/7.

  • This didn't solve the issue. Tried that from the recovery console of the Windows 7 dvd. – Scoregraphic Mar 10 '11 at 7:55
  • Hm, yeah the fact that it works even intermittently means it sounds like something more serious is incompatible. Very odd. – Mark Sowul Mar 10 '11 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.