Mac OS X has built-in support for internet connection sharing through the settings as in the following screenshot: http://mac.appstorm.net/wp-content/uploads/2009/04/sharingoptions-620x519.png

This works very well with other Macs, but I'm having problems connecting to such a network using Linux. I tried all combinations of configuration, double- and triple-check the WEP password but could never get an IP address. In a last effort I also tried without encryption, but still couldn't get my Linux box connect to the network.

I don't know if Windows has the same problem. Now I'm suspecting two things. Either I misconfigured something in my Linux installation, or OS X is doing something smart and makes it difficult for non-Apple devices to use the network (I also tested with an iPhone, it connects very well, unsurprisingly). Now what is wrong? What do I have to do?

  • 1
    Look at the avahi components. These are the components which talk to Bonjour. – BillThor Mar 9 '11 at 17:18

I would do a wireshark capture on your Linux box or possibly your Mac and pay attention to the DHCP requests and responses. This information may give you a clue as to what is going on assuming that your Linux box is able to establish a wireless link to your Mac in the first place.

The other thing you could try is to setup a static IP on your Linux box to bypass DHCP entireley. Pick an unused IP on the NATed subnet of the Mac and set the gateway and DNS server to the IP of the wireless interface on your Mac.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.