I have an Acer Aspire M5641 that won't boot. First, the onboard video stopped working; I bought a new compatible video card and connected it but it made no difference. I started some deeper analysis - below is what I've tried so far:

  • Cleared the CMOS
  • Removed all RAM
  • Removed all other peripherals (floppy, ODD, HDD, etc)

All of the above still had no effect on the POST. It will NOT beep whatsoever. The odd thing is that the fans spin and LEDs are on but still nothing.

My guess is a bad motherboard. Any ideas?

  • 1
    It's broke. Perhaps the CPU or bridge chip is bad. – Keith Mar 10 '11 at 3:05

That's most likely a failed motherboard, unless you're having a problem with the power supply not supplying the correct voltage (I've seen that before -- try taking out the battery and see if that works, and if it still doesn't you could always try with a third party power supply designed to work with your laptop).

At any rate, I hope for you that it's under warranty.

  • I tried removing the battery already while in the process of clearing the CMOS. I dont have anything to test the PSU with so I guess I'll stick to bad Mobo as the diagnosis. – ctzdev Mar 10 '11 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.