I recently have a problem with Remote Desktop (RD) on Windows 7. When I am in a RD session in full screen and click on the "minimize" button on the RD toolbar, the screen flickers, but the window does not go away. The only way to minimize for me is to first click on "restore" and then on "minimize" in the non-fullscreen RD session.

Anyone has a solution?


4 Answers 4


I had the same problem and it coincided with me altering the Windows 7 performance settings for "Best Performance". The item that caused my problem was "Animate windows when minimizing and maximizing".

To fix:

  1. Go to Control Panel,
  2. System,
  3. Advanced System Settings,
  4. (Performance) Settings.
  5. Click the Custom button, then tick the 2nd option from the top. I was immediately able to minimize RDP windows.
  • On my PC, the "Animate windows when minimizing and maximizing" was already enabled. Still, disabling the option and re-enabling the option fixed the problem for me.
    – oberlies
    Nov 12, 2013 at 12:40

Ctrl+Alt+Break: Switch the client computer between a window and a full screen.

  • 1
    That works, however, that is not what I want. I want to go directly from fullscreen to minimized. That is what is broken.
    – mauriceKA
    Mar 10, 2011 at 10:56
  • Try to do control-alt-leftarrow or control-alt-rightarrow but it hink this might only work for xp
    – ben950
    Mar 10, 2011 at 11:09

Try using ctrl+Alt+Delete , it opens up the original desktop, Choose task manager and switch to window you want.

was quick trick for me.


I am not doing Windows-7 to Window-7, but am using RDP from Windows-7. To minimize my desktop I move the mouse of the top of the screen in the middle. This gives me the connection bar from which I can minimize my remote desktop. You can pin the connection bar on the screen if you want.

  • 1
    This is not an answer to the question. The problem was not how to find the minimize button, but that it is not working. So this answer doesn't add anything useful.
    – oberlies
    Nov 12, 2013 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.