I noticed that the transparent interface in Firefox 4 for Windows 7 is really curbing performance. After Googling for a method to disable Aero for Firefox, however, I got no results. There just doesn't seem to be a straight forward (such as a simple Boolean to turn it off in about:config) method to get rid of Aero effects.

Is it even possible in the Firefox 4 beta? I'm using Firefox 4 beta 12 (soon to be RC after the update).

  • btw @Titus you might want to upgrade to Firefox 4 RC
    – Sathyajith Bhat
    Mar 11, 2011 at 6:00
  • Thanks for the heads up; I meant RC (After all the beta X updates, I kept thinking the next one was 13!) :D
    – Titus
    Mar 11, 2011 at 15:20
  • Updated my question to say RC instead of beta 13.
    – Titus
    Mar 11, 2011 at 15:45

2 Answers 2


You can disable Aero when you run FireFox by setting it's Windows compatibility options and check-marking "Disable Desktop Composition". But this will turn of Aero system-wide when you run FF.

There are others finding this problem as well, and it seems to be related to the new hardware acceleration in FF4, as witnessed at mozillazine.org's forums.

Testing suggestions from here:

To test if a problem you’re seeing is due to hardware acceleration, you can disable it. There are two ways to accomplish this:

•Run Firefox in safe mode. (All hardware acceleration is always disabled in safe mode.)

•Uncheck “Use hardware acceleration when available” in the Advanced section of the Preferences/Options dialog.

  • Thanks techie007! I'll look into it when I get home. Yes, hardware acceleration might be it; my laptop is a piece of crap. Also, thanks for the links. I hope the mozillaline.org forum will get fixed soon.
    – Titus
    Mar 11, 2011 at 14:45

To dispose of Aero in Firefox, use a persona - say, Vista Aero Firefox or Brushed. I hate the way Aero hinders reading the menus.

  • 1
    I've found "Wongs OS Integration Theme" to be an excellent choice for Windows 7. getpersonas.com/en-US/persona/78780
    – Starfish
    Apr 5, 2012 at 15:31
  • @Starfish That is a great and simple solution. Thanks!
    – Titus
    Apr 18, 2012 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .