I have a document and I would like to create a Table of Content.

I tried with Insert > Indexes and Tables > Indexes and Tables... and added a title, then I pressed OK.

But I only got a title and no Table of Content.

How do I add my headlines to the Table of Content? Should they be added automatically?

2 Answers 2


According to OpenOffice wiki every item which you want to see in the Table of Content must be styled as heading. So change style of titles of paragraphs to heading (1,2,3 etc.) and you will see them in the Table of Content.
Then right-click on the Table of Content and select Update Index/Table from the pop-up menu.

  • Ok, but how can I see what "style" my titles has, and how do I change them to be "heading (1,2,3 etc.)?
    – Jonas
    Mar 11, 2011 at 8:46
  • I read about how to applying styles, that helped. Thanks. wiki.services.openoffice.org/wiki/Documentation/…
    – Jonas
    Mar 11, 2011 at 9:06
  • Tried this in LibreOffice Writer, but did not work.
    – code_dredd
    Feb 21, 2017 at 22:35

Seems there is a bug on Google Docs. All the downloaded ODTs lack of the relation between the outline and the headings styles. Here is a similar question. Therefore, you have to fix the issue:

  1. Go to Tools > Chapter Numbering... (Outline Numbering on older versions), and select the paragraph style (probably "Heading 1" for Level 1 and so on... up to level 6.


  2. Then update the ToC:


Update: It seems fixed on newer versions (6.0+).

  • 1
    As of Libre Office (November 2017), this is still good and useful advice. Without it, Tables of Contents do not appear until you associate Level 1 with the Heading 1 Paragraph Style, as shown above. The only thing I'd add is that once you've done this, you just need to return to your ToC, right click, and choose Update Index (even though it's a ToC). You should then see your paragraph and chapter headings.
    – Jon
    Nov 5, 2017 at 10:23
  • Thanks @Jon. I added your suggestion with a screenshot. Please upvote if you find this answer useful.
    – Pablo A
    Nov 6, 2017 at 20:35
  • Still the same issue in Version: In addition, to refresh the ToC I have to go in: Tools > Update > Update All. Btw, thanks for the Chapter numbering trick, I was unable to figure out where the hell was the Outline numbering because it simply doesn't exist on this version!
    – s.k
    Mar 26, 2020 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.