I'm trying to install QtiPlot on Mac OS X, but I can't compile it since qmake isn't known. How can I install qmake on Mac OS X?

6 Answers 6


Homebrew version

$ brew install qt
  • 7
    Better than MacPorts! Nov 5, 2013 at 4:46
  • 2
    If you get Error: Qt currently requires --HEAD on Mavericks, run brew install qt --HEAD (requires git). Jan 28, 2014 at 3:37
  • 5
    While qmake does exist in the Homebrew package, it doesn't appear to be symlinked by default anymore. Try brew link qt Or if that doesn't work: ln -s /usr/local/Cellar/qt/<QT_VERSION_HERE>/bin/qmake /usr/local/bin/qmake
    – TrinitronX
    Dec 5, 2017 at 20:47
  • 1
    If you need specific version of qt, for example 4.8.7_2: use brew switch qt 4.8.7_2. Make sure you add it to PATH: export PATH="/usr/local/opt/qt/bin:$PATH"
    – TrinitronX
    Dec 5, 2017 at 20:53
  • 3
    @TrinitronX's suggestion is good to use brew link qt, but I had to use --force. Here's the whole command: brew link qt --force. To verify it worked, then run which qmake to print out the path to qmake.
    – kbpontius
    Nov 6, 2019 at 16:29

Just to elaborate for anyone who finds that after installing qt5, can't access qmake in the terminal.

Install QT5 using:

brew install qt5

Then to allow access qmake from the terminal you'll need to run:

brew link qt5 --force
  • Perfect, works like charm :)
    – schlenger
    Mar 28, 2022 at 9:18

Just got it!

  1. Install MacPorts: http://www.macports.org/

  2. On Terminal: sudo port install qt4-mac

Then, I got qmake. You can install qtiplot directly by running: sudo port install qtiplot. Process takes about 3h.

  • 3
    It appears that either updating the path, or manually symlinking qmake is now needed: stackoverflow.com/a/31318672/1959808
    – 0 _
    Nov 11, 2015 at 23:10
  • 1
    e.g. /usr/bin/sudo ln -s /opt/local/libexec/qt5/bin/qmake /opt/local/bin/qmake
    – Goblinhack
    Oct 18, 2020 at 18:10

The official Qt installer, including qmake, is available from nokia at http://qt.nokia.com/downloads, but BE CAREFUL:

The so-called "SDK" download, which appears near the top of the page is not what you want. Maddeningly, qmake and other needed tools are available from the "Qt Libraries" download. Scroll down the page and find "Qt libraries". This gets me confused every time I install Qt on the Mac.


QMake is part of Qt since 3.0, earlier versions had tMake.

So, either look for tMake instead or install/upgrade your Qt to get QMake, good luck!

  • I don't have Qt installed. I just want to install QtiPlot, but their documentation isn't intuitive. Mar 11, 2011 at 12:46
  • You will need the Qt-devel and Qt-config and their dependencies in order to have QMake Mar 11, 2011 at 12:48
  • Thanks, do you know any alternative to qmake? Mar 11, 2011 at 13:01
  • 2
    @FábioPerez: No, QtiPlot is written with the intent that QMake generates the Makefiles. Mar 11, 2011 at 13:03

For installing Qt5 with brew, you can do

brew install qt5

  • 2
    Isn't this essentially the same as the accepted answer (wouldn't anyone doing the installation recognize a name change and understand to use the actual name of what they want to install)?
    – fixer1234
    Nov 16, 2014 at 5:27
  • 1
    This gave me qt5 but not qmake. I only get qmake with brew install qt, but then it is the old version of qmake :( Sep 2, 2016 at 10:55
  • worked for me by also doing what suggested by elMarquis Dec 9, 2016 at 10:25
  • Can't work out whether it's a synonym in Homebrew, but it does the same thing as brew install qt. Today's homebrew recipe doesn't symlink qtmake sadly.
    – paul_h
    Dec 30, 2017 at 12:15
  • This absolutely includes qmake. See elMarquis's answer.
    – user59659
    Sep 21, 2018 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .