A few weeks ago, I noticed that my Internet connection had slowed down to a crawl. I waited a few days hoping it would go away on its own, but it didn't get better. So I asked this question about how to make it faster.

The problem went away after I updated to the latest firmware, so I didn't follow up too carefully. But every few days since then, my Internet has slowed down again. Unlike before, all I have to do to fix it is open the router administration page and press the "Reboot" button. Nothing else seems to work, though I'm sure there are options I haven't tried.

If it makes a difference, my girlfriend and I both transfer large amounts of data fairly routinely for school (videoconferencing, downloading entire recorded lectures).

The router is a Cisco/Linksys WRT160N v3 that's about a year old. Most of the time, it deals with just two standard Windows 7 laptops.

The only thing I came across while searching for answers/dupes was this unresolved question, which seems similar superficially, but probably doesn't have the same root issue.

What could be causing these slowdowns, and how can I get rid of them?

After asking this followup question, I installed dd-wrt on my router, and I seem to be getting higher and more consistent speeds. Perhaps more importantly, my memory use is fairly constant. I know this isn't an answer — which is why I'm not posting it as an answer — but it is how I resolved the situation, and hopefully it'll be helpful for someone.

  • 1
    Linksys routers, in my experience, need an occasional reboot. While I don't know the reason for it, I've learnt to live with it.
    – user3463
    Mar 12, 2011 at 0:16
  • 1
    I've had the same issue with an old D-link (very old, I no longer use it). The problem causing the issue is best described in technical terms as "dodgy firmware". In other words, there are firmware defects. Mar 12, 2011 at 0:20
  • What @RandolphPotter said. Linksys makes good routers, but they need a reboot every week or two.
    – Shinrai
    Mar 12, 2011 at 0:25
  • 1
    All SOHO routers are guilty of this. Linksys, Netgear, Dlink, Airlink101, Buffalo, Belkin, 3Com, etc, all will have this trait commonly. If you want a router that will last much longer and has more memory and faster processor clock cycles, purchase a Cisco, Samsung, Sonicwall, Adtran, Edgewater, etc.
    – MaQleod
    Mar 12, 2011 at 3:24

5 Answers 5


I'd say that the problem is bad memory management in router firmware. Basically whenever router needs to have lots of connections open, it uses up its RAM, which is normal. When a connection is closed, that RAM should be freed up. It looks like in your case it isn't. As router has less and less RAM available, it becomes slower and slower and in the end you have to reboot it. When it is rebooted, contents of the memory are cleared and you have fresh memory to use.

If that's the case, then there's very little you can do. Your router may be supported by third party firmware like DD-WRT or OpenWRT (where's the rest of its name? I can't tell without it) so you could try installing one of then. Otherwise, you could hope for new version of official firmware which could fix the problem.

To check if I'm right, try opening lots of windows and tabs in your browser and go to as many websites as you can on as many computers as you can. Also, you could try finding a hot torrent and download it. Bittorrent will usually place heavy load on router and if the connection closing problem is there, it will occur quickly.

I had a similar problem on a Netgear FVG318 router and solved it by getting a router which supports OpenWRT. I haven't had any problems since then.


In situations like this I love to take a cheap garden timer from Home Depot/Any Hardware store and set it to reboot the router on a daily basis in a time when theres generally little to no usage.

  • 3
    That's... actually pretty clever. I'm guessing a garden timer is the thing that turns your sprinklers on at the same time every day?
    – Pops
    Oct 25, 2011 at 17:40
  • 1
    Or the thing you use to turn on your Christmas lights :) Oct 25, 2011 at 17:57
  • 3
    I do that manually. It's fun!
    – Pops
    Oct 25, 2011 at 17:58
  • 1
    I always forget to turn them off, my electric bill for holiday season is usually a beast. Oct 25, 2011 at 17:59
  • 1
    Here's an upvote for a solution to my once-a-day FVS-114 power plug removal. Seems like after it hits a certain number of NAT entries, it bogs or locks up. Has been upgraded to the latest firmware. When I answer whether DD-WIRT passes VPN traffic or not, I'll probably replace it, though wires breaking off the plug from flexing during reboot will be the real spur for change. Your solution would prolong it's life which might be the reason for the down vote. Oct 25, 2011 at 18:08

This is an issue I have dealt with for the last 5 years or so with 2 different Linksys models and 4 different laptops. While I have not found any permanent fixes, I have found a solution that is quicker than rebooting the router and/or pc and doesn't interrupt any devices connection to the internet.

Steps 1 and 8 are optional, but it's a good way to verify the effectiveness of this method.

  1. Go to speedtest.net and test your speed [Average pre-fix test ~ 2Mbps/~1Mbps]
  2. On a Windows PC, Open Device Manager
  3. Click to expand Network Devices
  4. Right click on your wireless adapter and go to properties
  5. Click the advanced tab
  6. Change any value of any setting and click okay
  7. Then change it back and click okay
  8. Go back to speedtest.net for another speed test [Average post-fix test ~ 20Mbps/~5Mbps]

My quoted speeds are 20/5, so after this fix, I get my full bandwidth; however, if there are other devices active on the network, the second test will give you a good idea of exactly how much traffic the other devices are using. Apparently my roommate is trying to download the entire internet's collection of porn in preparation for a zombie apocalypse :P

  • Thanks.Tried several posted solutions, and this one was the only one that worked for me. It seems to be restarting the driver or resetting it in a lightweight fashion. Using Device Manager to disable/enable the device might do the same (will try next time) and it would be bit quicker to do with less navigation through menus and dialogs.
    – dachiz
    Dec 17, 2023 at 17:26

For Linksis Routers, go to Utilities tab and check the Firewall selection. By Disable (turn off) the router Firewall. It speed up the internet connection a lot. It is better than rebooting quite often.

You should turn off your router at night or at non usage time as routers that are turned on 24hrs are subjected to over heat and subject to hang due to triggering of the firewall feature.

After I solve my router problem by turning off the firewall, I switch off the router at night too to prolong the router life.

  • 3
    Not really a wise thing to do, accessing the internet without a firewall can be dangerous.
    – slm
    Jan 6, 2013 at 15:44
  • And, of-course, rebooting the router frequently puts a heavy load on it at startup - by far the most likely time for a PSU failure - especially on Linksys devices (don't know this one, but the PAP2's are legendary for that).
    – davidgo
    Feb 19, 2013 at 6:00

I just had this situation, cable tech said it was the wireless router. So I bought a new one, same issue. Then on a whim, changed cable from modem to router and lightning fast again. Sometimes it really is the simple things.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .