8

I used Windows XP for years, before I was able to get my hands on Windows 7 RC, which I bought a new HDD for, and setup to dual-boot. About a month ago, Windows XP started acting funny, and I thought the disk might be dying, so I started using Windows 7 all the time.

Today I started the computer, and it can't find the disk which Windows XP was installed on anymore. I guess it's dead. So, I removed the hard drive that had Windows on it, and now my computer won't start - I get an error message that says insert bootable disk (or something similar).

How do I remove the primary (dead) hard drive that has Windows XP installed on it and boot straight to Windows 7?

0

5 Answers 5

13

You should be able to fix it by booting from the Win 7 DVD using these instructions

http://www.sevenforums.com/tutorials/668-system-recovery-options.html

and doing the startup repair.

Edit: As we discovered later I should have said to unplug the damaged xp drive first.

5
  • so what would you do if that didnt work? Aug 21, 2009 at 12:46
  • Did you check the bios to make sure your hard drive is the first boot device?
    – Col
    Aug 21, 2009 at 15:23
  • Just a thought, did you run the startup repair with or without the xp hard drive in. You'd need to run it without it.
    – Col
    Aug 22, 2009 at 7:23
  • Haha if you had only said that to me 10 hours ago-i did try several different ways but i think i must have missed that one! D'oh! Oh well just another learning experience :) Aug 23, 2009 at 22:44
  • Hey, at least it's sorted
    – Col
    Aug 24, 2009 at 7:35
1

Edit: It's maybe better to try Col's suggestion first. As that one is simpler. If it doesn't work you can resort to this one though.

I suppose your XP disk was the primary and active one, from which your computer booted, so it's normal that your PC doesn't boot anymore after taking that one out. You will have to make your Windows 7 disk Active and bootable by changing its master boot record.

I've found a nice tutorial how this can be done here.

It basically comes down to booting your PC with the Windows 7 install DVD into Command Prompt mode and issuing a

bootsect /nt60 SYS
1

I had the same problem. My BIOS had the option to boot to a specific hard drive. Check your BIOS settings to make sure it is booting to the correct hard drive.

0

Sounds like a Master Boot Record issue.

Check this article: MBR - Restore Windows 7 Master Boot Record

0

It's possible that your Win7 harddrive is set to slave, and the WinXP harddrive was set to master. You can change this, but to do it you need to open the case, and switch the little plastic jumpers on the back of the harddrive, next to where the power plugs into it.

Photos here: http://www.onlinecomputertips.com/hardware/hd_jumpers.html

1
  • 1
    Of course, this is only applicable if you're using IDE hard drives. SATA hard drives don't have primary/slave jumpers. Aug 19, 2009 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.