I have three networked Macs of varying ages, running slightly different versions of OSX. Only one, in the office, is linked to a printer, but I print documents from the Macbook Pro using wireless networking to this machine. Suddenly, though, while the machine with the printer can find the Macbook Pro on the network, the Macbook Pro finds the name of the office computer, but then gives me its own files and drives rather than the office computer's when I go to connect. I have tried renaming the office computer and connecting it to a different port on the hub without making any difference; I have been through the networking and file sharing options in the office machine's system preferences without spotting any changes or anything that might help resolve the problem.


Maybe there's a Bonjour problem going on. Rather than browsing for it or clicking on the link the a Finder window's sidebar, try connecting explicitly to the IP address of the machine using "Go > Connect to Server..." (Cmd-K) in the Finder. If you still get shown your own files that way, try troubleshooting Bonjour using the dns-sd(1) command line tool like this:

First, use -B to Browse for the AFP service. Once the list populates and you see a listing for the machine you're interested in ("My Bad AFP Service" in the example below), Ctrl-C out of dns-sd.

$ dns-sd -B _afpovertcp._tcp local
Browsing for _afpovertcp._tcp.local
Timestamp     A/R Flags if Domain                    Service Type              Instance Name
 9:30:13.776  Add     2  6 local.                    _afpovertcp._tcp.         My Bad AFP Service

Now use -L to Look up the host and port on which the AFP service you care about is running. Again you'll have to Ctrl-C out of dns-sd.

$ dns-sd -L "My Bad AFP Service" _afpovertcp._tcp local
Lookup My Bad AFP Service._afpovertcp._tcp.local
 9:30:33.221  My\032Bad\032AFP\032Service._afpovertcp._tcp.local. can be reached at My-Bad-AFP-Service.local.:548 (interface 6)

Now use -Q to do a local Multicast DNS Query for the hostname of the machine hosting the service in question, to see what IP address you get back.

$ dns-sd -Q My-Bad-AFP-Service.local
Timestamp     A/R Flags if Name                             T   C Rdata
 9:31:00.677  Add     2  6 My-Bad-AFP-Service.local.        1   1

Finally, look at what IP address you got back, and make sure it's the correct IP address for the target machine, not a loopback address like or your own client machine's address, or some other address that somehow relates to your client and not the target machine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.