I have a 2.5" external hard drive that is failing. It's not making the expected 'clicking' noise that most hard drives and I am able to view the data, but I am unable to actually retrieve the data.

  • I attempted to use SpinRite in order to access the data on the drive, but it didn't like the external drive.

  • When I view the drive's property page, the drive shows that it's used space is at 100% and that it has 0 bytes available; however, the progress indicator under the drive icon in Windows Explorer shows that it's roughly 50% full (which is correct).

  • When I attempt to run Windows' "Error Checking" tool and attempt to "scan for an attempt recovery of bad sectors," the tool begins to run then immediately closes with no error message.

  • I am able to browse the contents of the drive using Windows Explorer. When I begin to try copying any given single file, the copy process begins, an indicator starts, and then the copy fails with no real error message.

  • The Disk Management page in Computer Management under Control Panel also shows this drive has being 'Healthy.'

  • I dropped the drive off at a data recovery store and they said that "The data seems to be intact, but an internal failure is preventing any information from being retrieved." They offered to provide me references to a data recovery specialist.

  • I've also attempted to run CHKDSK on the drive (with and without arguments) but it returns the following error: The type of the filesystem is RAW. CHKDSK is not available for RAW drives.

Before going the route of more expensive data recovery, I'm wondering if these symptoms sound familiar to anyone?

Other questions...

  • I'm willing to continue trying tools such as TestDisk and/or PhotoRec (as the majority of the data that I'd like to salvage are photos) but how long I should expect either tool to run given approximately 400GB of data?

  • I'm also comfortable using Linux so I welcome any suggestions for utilities or tools and strategies with which you've had success.

Edit 3/15/2011

It appears as if I have a failed MFT. At this point, it looks as if I may be looking to a data recovery specialist (unless anyone has suggestions from this point).

  • Does "view the data" mean list files in directories? What file system is used on the drive?
    – Bittrance
    Mar 12, 2011 at 21:29
  • "View the data" means I can view all files and directories on the hard disk - I just can't read them from disk nor copy them to another disk.
    – Tom
    Mar 12, 2011 at 23:52

5 Answers 5


You should try using ddrecover instead of dd. It will be able to read past bad sectors, where dd would just stop and abort.

 dd-recover /dev/devce_name /path/to/drive/image

It will take a while, but should be able to recover most of the data. You can use a Linux live-cd to do this. If using Ubuntu, you'll need to install the package 'ddrescue' once booted. I just did this myself recently. Once you've recovered the image, you can then use dd to put it back on a new drive and use chkdsk to fix any problems in the image.

  • Thanks - noted. Going to try this. I'm expecting this to take on the order of eight hours or so. How long was yours time? Additionally, if it bypasses bad sectors, I imagine certain files will likely be corrupt, correct?
    – Tom
    Mar 12, 2011 at 22:07
  • Mine was rather short, as I was only imaging a 40GB laptop drive that was failing. It took roughly and hour to an hour twenty to image off to a CIFS share I had set up. The copy back went much quicker, only about 20 minutes. I was using Gigabit with Jumbo frames, though. I also set bs=1024K for dd when copying back.
    – GhettoSA
    Mar 13, 2011 at 4:06

If the drive is mechanically sound, just swapping out the logic board with an identical drive may get things working.

Depending on the root cause, you could try sticking the drive in the freezer a while and then retrying extraction.

As mentioned, dd-recover should extract the most blocks possible, then you can run photorec on the saved image.

Good luck!

  • @Paul - swapping the logic board is going to be a last resort. I want to try to solve this as much as possible without doing that kind of 'sugery' ;) .. still, thanks - may have to do it anyway.
    – Tom
    Mar 12, 2011 at 23:53
  • I've swapped boards before, and it can work, but it's very hit or miss even when you do have an identical drive available. Considering the board design, and firmware, usually change from one manufacturing run to another.... It should be a last ditch effort that is expected to fail.
    – Scott Pack
    Mar 13, 2011 at 16:51

I would not try the freezer trick. It is better to let it cool down to room temperature and try that. The freezer trick has been reported to have worked in some situations, but it can also freeze out the condensation in the air and deposit it on the platters. On older drives this was not a big problem, but on modern drives the flying height is a few nanometers and can cause a head crash before you know it.


To me, it sounds like a FAT partition where the allocation table has been trashed. This may be the case if it is a USB drive, wheich tend to be FAT, I think.

At the risk of trying to lend false hope, you could try to stick the disk in a Linux box and dd the entire partition(s) into a file on a different disk. If that works, you can try various forms of recovery without risking further damage to the disk.


dd if=/dev/sdX1 of=/path/of/image bs=1M

Then you can do photorec to your heart's content.

  • That thought crossed my mind, but the drive is NTFS, IIRC. At any rate, once I get the disk back from the data recovery center, I'll give this a try.
    – Tom
    Mar 12, 2011 at 21:49

Try doing a chkdsk /r on it and see if that actually completes.

If the drive has a hardware issue and simply can't be read due to some physical issue, you can try (as a last resort) to swap the platters out on the exact same hard drive model. I have never personally done it but I do know it is a data recovery technique. Find the exact same model hard drive, open it up and swap your HDD platters with the good one, close it back up and connect it. Note that I am indicating that this is a last resort before spending 1 grand to have a third party get your data back.

  • Unfortunately, when I run chkdsk I get an error message regarding 'RAW' file system. I've updated the question to note this, too.
    – Tom
    Mar 12, 2011 at 21:51
  • Just to be clear: you don't open the drive and take the individual platters out (that's a sure way to make the drive absolutely unreadable), you find the same model drive, and swap the controller boards. Mar 13, 2011 at 7:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .