2

Thinking of converting my Windows 7 Boxee box to Ubuntu to ease up on RAM and CPU load, but I can't find a method of mounting the airport disk.

I have found a package called airport-utils, but I can't find explicit information about the disk functions. I really can't switch without this functionality.

1

Yes, AirPort Extreme and Time Capsule both share their USB disks via both AFP (Apple File Protocol, the default remote filesystem mounting protocol for Macs) and SMB (Server Message Block, the default remote filesystem mounting protocol for Windows, which is what the open source "SaMBa" server serves). So the SMB client in Ubuntu should be able to mount your AirPort Extreme's USB disk just like it mounts a Windows server or Linux Samba server.

6

I was able to do it using the following commands:

sudo apt-get install cifs-utils

sudo mount.cifs //IP_ADDRESS/Data ~/capsule -o password=CAPSULE_PASSWORD,sec=ntlm,uid=LOCAL_USERNAME
  • Thanks - this actually worked better for me than Steve HHH's answer with Ubuntu 14.04 – cwd Jan 22 '15 at 5:05
  • Cheers! I have seen that linux mint auto mounts AirPort Extreme disks when scanned.. Get the latest one – Kajal Sinha Jan 22 '15 at 5:07
  • This worked for me. But I do believe Steve HHH's answer is completely valid depending on what option you choose within your AirPort Extreme settings. These instructions are for the "Use the device password" option whereas Steve HHH's solution I believe is for the option which has access setup for individual users (I forget the exact option name). – pumazi Mar 5 '17 at 3:50
5

I was able to mount my 2008 Airport Extreme's external USB drive in Ubuntu 12.04 with the following command:

sudo mount -t cifs //10.0.1.1/SHARE -o username=stevehhh,password=mypasswd /media/airport

Note that you'll need to customise the above command for your own Airport setup, by ensuring that the following parameters are correct for you:

  • The IP address of your Airport Extreme (above, mine is 10.0.1.1).
  • The name of the share (above, it's "SHARE").
  • The username to access the share (I just used the same username as on my Mac: stevehhh, which happens to also be my username on the Ubuntu system. However, I can still connect even if I set this to a non-existent account, such as foofoo123. If I omit the username parameter altogether, however, the mount command fails).
  • The password for the Airport share (above it's "mypasswd").
  • The name of a folder where you'd like the Airport drive mounted (above, /media/airport).
1

Solved by adding vers=1.0 at the end of the mount command:

sudo mount -t cifs //IP_ADDRESS/FOLDER -o 
username=LOCAL_USERNAME,password=AIRPORT_PASSWORD,sec=ntlm,vers=1.0 

Version 2.0 (i.e. vers=2.0) did not work (was also suggested).

-- Ubuntu 18.04.1 LTS

-2

Wouldn't bother. Check this out: https://support.apple.com/en-us/HT202807 So with SMB it supports only up to real old FAT32, allowing max 32GB volumes and max 4GB File size. No NTFS, no ExFAT. Maybe the apple proprietary files systems may work, but not supported in combination with SMB. Here I am staring at a 1TB drive with up to 12GB sized files and my airport extreme. Oh well.. So much for that one.

  • 1
    -1. From your link: "If HFS+ formatting is used, AFP and Microsoft SMB/CIFS protocols are used to share the device on the network". If I read this right, it disagrees with your statements. Have you even tried HFS+ with SMB? As for now the answer is inconsistent and probably misleading. – Kamil Maciorowski Jun 21 '16 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.