I have a BSOD on windows 7 with SSD during boot after improper shutdown (while windows animation logo is moving). The computer restart imediatly after BSOD, and windows proposes to launch startup repair (if i do it, it takes +-5min and fixes the problem : computer starts normally). However, after any new improper shutdown, i got the same problem. Remarks:

  • If i unplug, re-plug the SSD whyle system is shutdown, i have the same problem.
  • If i reproduce the situation with old HDD, i havn't the problem
  • Previously, i had a different problem: BSOD when waking up after sleep, which was fixed by installing drivers (ethernet, usb, graphic card)
  • I have made ram chech and ssd check and found no problems
  • Starting with safe mode after improper shutdown causes a BSOD at loading of classpnp.sys


  • System: HP compaq 8510p
  • SSD: OCZ vertex-2 2.5
  • Boot options: SATA native mode -> Enable, HDD transalation mode -> LBA-assisted

Edit: The BSOD says: A problem has been detected and windows has been shut down to prevent damage... ... run CHKDSK /F (i did, found no error)... Technical information: *** STOP : 0x0000007B (0XFFFFF880009A9928; 0xFFFFFFFFC0000034, 0x0000000000000000, 0x0000000000000000)

After the repair, i have: "Root cause found: unspecified changes to sysem config might have cause the problem"

With windbg, by oppening both minidump and MEMORY.DMP, i have the folowing: "Probably caused by wininit.exe, Followup: MachineOwner"

  • Needs more details. What kind of SSD is this? Are you in IDE or AHCI mode? What AHCI driver are you running? – Shinrai Mar 14 '11 at 14:44
  • I don't know anything about ahci. In the boot options, i see no ahci or ide configuration. In the device mannager, i have "IDE ATA/ATAPI controllers" -> intel(R) ICH8M-E/M SATA AHCI Controller, device type -> IDE ATA/ATAPI controllers, provider -> intel. So i guess i am in IDE mode – Benjamin Crouzier Mar 14 '11 at 15:05
  • Sounds like you're in AHCI mode but the proper place to check is in the BIOS - usually under SATA configuration or something like that. – Shinrai Mar 14 '11 at 15:33
  • In the BIOS, the only option related to SATA i have is "SATA native mode". So maybe this triggers IDE-AHCI mode, because when i change it to "disable" i have not the bsod roblem, and i have slightly lower disk performances. – Benjamin Crouzier Mar 14 '11 at 18:24
  • @Bob: Interesting, maybe the BIOS has reset due to the improper shutdown? – Tamara Wijsman Mar 14 '11 at 20:50

Based on your most recent comment, it does sound like a problematic AHCI driver. You should try updating any chipset drivers and making sure the firmware on the SSD is current; that may well be enough to clear the issue up on its own.


Looking for a problem description.

I have a BSOD...

After reading four words, I question myself "What BSOD?" or better said "What's the actual problem?".
There is useful information on there, if you just tell us your PC got the blues then we can't help you.

Try to read the error code or name and see if you can get the dump file from the disk...
The files of interest are C:\Windows\MEMORY.DMP and anything in C:\Windows\MiniDump.

Given that the crash occurs during the Windows Logo there is most likely access to the disk thus a dump will be saved there, and given that the BSOD only shows shortly it most likely is a MiniDump, can you upload the most recent ones so we can analyze them?

...after any new improper shutdown, I got the same problem...

If it were the exact same problem, the exact same solution would work.

...and gave some more details and the steps I tried.

All other details are irrelevant and troubleshooting was unnecessary as you don't know the problem.

Get more details about the minidump by analyzing it with WinDbg.

Windows 7 Kernel Version 7601 (Service Pack 1) MP (2 procs) Free x64
Built by: 7601.17514.amd64fre.win7sp1_rtm.101119-1850

So we have Windows 7 x64, updated to the RTM version of SP1. Good that it's up to date...

Debug session time: Wed Mar 2 03:45:55.660 2011 (UTC + 1:00)

The crash occured on March 2, are you sure you don't have a more recent crash?
Or was that the last time you have boot your system?

Anyhow, let's analyze it; if you don't want WinDBG, check this online alternative:

1: kd> !analyze -v

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

A process or thread crucial to system operation has unexpectedly exited or been
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arg1: 0000000000000003, Process
Arg2: fffffa80051fa4c0, Terminating object
Arg3: fffffa80051fa7a0, Process image file name
Arg4: fffff80002d8fdb0, Explanatory message (ascii)

Debugging Details:
PROCESS_OBJECT: fffffa80051fa4c0
IMAGE_NAME:  wininit.exe
MODULE_NAME: wininit
FAULTING_MODULE: 0000000000000000
PROCESS_NAME:  wininit.exe
EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.
fffff880`067700e8 fffff800`02e14982 : 00000000`000000f4 00000000`00000003 fffffa80`051fa4c0 fffffa80`051fa7a0 : nt!KeBugCheckEx
fffff880`067700f0 fffff800`02dc20ab : ffffffff`ffffffff fffffa80`05481b60 fffffa80`051fa4c0 fffffa80`051fa4c0 : nt!PspCatchCriticalBreak+0x92
fffff880`06770130 fffff800`02d45698 : ffffffff`ffffffff 00000000`00000001 fffffa80`051fa4c0 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x17ad6
fffff880`06770180 fffff800`02a8b8d3 : fffffa80`051fa4c0 fffff800`c0000006 fffffa80`05481b60 00000000`02190d10 : nt!NtTerminateProcess+0xf4
fffff880`06770200 fffff800`02a87e70 : fffff800`02ad811f fffff880`06770b78 fffff880`067708d0 fffff880`06770c20 : nt!KiSystemServiceCopyEnd+0x13
fffff880`06770398 fffff800`02ad811f : fffff880`06770b78 fffff880`067708d0 fffff880`06770c20 00000000`ffc4b938 : nt!KiServiceLinkage
fffff880`067703a0 fffff800`02a8bcc2 : fffff880`06770b78 00000000`02210000 fffff880`06770c20 00000000`ffc4f894 : nt! ?? ::FNODOBFM::`string'+0x49974
fffff880`06770a40 fffff800`02a8a83a : 00000000`00000000 00000000`ffc3ec6c 00000000`00000001 00000000`02210000 : nt!KiExceptionDispatch+0xc2
fffff880`06770c20 00000000`76fa8f55 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
00000000`021912d0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x76fa8f55

FOLLOWUP_NAME:  MachineOwner
BUCKET_ID:  X64_0xF4_IOERR_IMAGE_wininit.exe
Followup: MachineOwner

Reading the analysis

  1. Bug Check 0xF4: CRITICAL_OBJECT_TERMINATION occurs when a system process or thread is terminated for any reason, the system can no longer function.

  2. Argument 1 of the Bug Check is 0x3 which indicates that a process has been terminated.

  3. Argument 2 points to the terminated process, the debugging details reveal that this is wininet.exe
  4. Argument 3 points to the name within the terminated process structure, as seen in step 3.
  5. Argument 4 points to the reason why that process has been terminated, which is:

    (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p.
    The required data was not placed into memory because of an I/O error status of 0x%x.
  6. The rest of the details does not reveal any specific driver module but just locations inside the kernel as they begin with nt!. It does reveal a driver fault though, but that's most likely be the driver that allows your data to pass from your hardware to your software. This Microsoft driver is guaranteed to be stable, so it's not a driver problem but more likely to be a hardware problem.


In step 5 we discovered that data is being read at a specifc location in memory (as we use a minidump, that location is unavailable) but that data has been paged out to the disk so it performs an I/O operation to get that data from the disk.

In step 6 we discover that it's more likely to be a hardware issue, as you lost power it's most likely that your SSD has became damaged or that data in your SSD cache has been corrupted. I think the only solution is to reinstall your system, disabling disk caches and taking regular back-ups.

There is not much you can do to fix that corruption without reinstalling, and if it really is damaged or malfunctioning due to a manufacturing mistake you'll have to go for warranty or worst case, buy a new.

  • I've put the latest minidump here: pinouchon.com/sites_tmp/misc/minidump.dmp – Benjamin Crouzier Mar 14 '11 at 18:15
  • @Bob: Updated the post, it's most likely to be corruption or damage. – Tamara Wijsman Mar 14 '11 at 20:49
  • Thank you for taking time to answer my problem, and explaining me WinDbg troubleshooting process. However, as Shinrai pointed out, i've tried some AHCI drivers. I've tried out the versions and, both causing the problem. Then I tried an older driver: on HP website (search link named "Intel Matrix Storage Manager Driver"). And the big surprise is that this older driver works. So i think the problem was linked to the AHCI driver. Now, i wonder why a more recent and official release of the driver would cause the kind of problem I have. – Benjamin Crouzier Mar 15 '11 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.