1)Win7 x86 SP1 won't install
2)Found "corrupt" update on system using CheckSUR: KB2479628
3)Can't uninstall/reinstall update with any known methods

This is going to be a long drawn out scenario so bear with me. Here are the background details:

Over the weekend I had the task of installing Windows 7 SP1 to any applicable servers during downtime. All of the servers updated fine save for one pesky Win7 Pro 32-bit virtual machine we use for testing. Since it is a non-critical box I ignored it and went on completing other checks figuring I would get to it later. Today I've spent about 3 hours troubleshooting why exactly this thing won't update to SP1. The error code I get using Windows Update is 0x800F080D.

Using google I stumbled upon the CheckSUR tool that can be used to check for any errors or missing features that would be needed for updates: http://support.microsoft.com/?kbid=947821

After running that I looked in %windir%\logs\CBS\CheckSUR.log which revealed the following:

Checking Package Manifests and Catalogs
(f) CBS Catalog Corrupt 0x800B0100  servicing\Packages\Package_2_for_KB2479628~31bf3856ad364e35~x86~~        
(f) CBS MUM Corrupt 0x800F080D  servicing\Packages\Package_for_KB2479628_RTM~31bf3856ad364e35~x86~~      
(f) CBS Catalog Corrupt 0x800B0100  servicing\Packages\Package_for_KB2479628_RTM~31bf3856ad364e35~x86~~      
(f) CBS MUM Corrupt 0x800F080D  servicing\Packages\Package_for_KB2479628~31bf3856ad364e35~x86~~

Checking Component Store
(f) CSI Manifest Failed Catalog Check   0x00000000  winsxs\Manifests\x86_f352a6c8c5baa79b60637048ed291c9c_31bf3856ad364e35_6.1.7600.16732_none_1611ae244ffc9218.manifest    x86_f352a6c8c5baa79b60637048ed291c9c_31bf3856ad364e35_6.1.7600.16732_none_1611ae244ffc9218

At least that narrowed it down to one corrupt update. Easy enough, I'll just go into Programs and Features and uninstall it. That's when I realized it wasn't even listed as being installed. Something must have gone horribly wrong with this update at some point.

I looked through the registry and found a ton of entries for this update. None of the values or keys could be deleted in order to trick the system into reinstalling the update. Same goes for the actual package files at %windir%\servicing\Packages\ that were referenced in the CheckSUR.log. Windows complains that it needs permission from SYSTEM to modify or delete files even when I am logged in as an Admin.

I did manage to find the stand-alone msu installer here: http://www.microsoft.com/technet/security/bulletin/MS11-012.mspx

When I run that msu I am told that the update has already been installed.

I then went through the list of all 3 of the manual methods for a manual uninstall listed on this page: http://www.sevenforums.com/tutorials/109213-windows-update-uninstall-console-level.html

None succeeded. I get this error using method II and III which seems pretty generic: 0x800B0100 No signature was present in the subject.

I also tried to open up the cab file for this update and manually replace the .mum and .cat files that were said to be corrupt but ran into the SYSTEM permission issue.

Haven't tried doing any of this Safe mode yet thinking it wouldn't be any better.

I've also tried running sfc /scannow in safe mode which gives that oh-so-helpful message that it found problems with files but couldn't fix them.

Is there something I'm overlooking or is this Win7 box basically stuck without SP1 until I can reinstall? Maybe use a LiveCD and manually replace those .cat and .mum files outside of Windows? Would really like to do this in a way that won't make windows update throw a fit later.

Thanks for any help!

  • Well I did manage to fix that problem KB2479628 update using instructions from here: technet.microsoft.com/en-us/library/ee619779%28WS.10%29.aspx Turns out you want to put those .cat and .mum files into %windir%\Temp\CheckSUR\servicing\packages instead of trying to directly overwrite the %windir%\servicing\packages files. Once I put the exploded cab files into that directory and re-ran checksur it went through fine. Still can't get SP1 to install, getting an error code 80070643 now but I've gotten to the point where I don't care anymore. – Diffuser Mar 15 '11 at 15:52

Windows 7 SP1 adds nothing new to your system its just all previous updates rolled into one only useful for reinstalling.

You could try disabling Automatic Updates/BITs services removing C:\Windows\SoftwareDistribution and re-enabling the two services then installing SP1 I would make a system restore point to be safe though.

If that fails I would just start over with SP1 installed since its a testing machine.

  • Tried to disable auto update and reset the SoftwareDistribution directory but it still won't let me install SP1, gives the error code I mentioned above. Oh well, just gonna have to let this one slide. – Diffuser Mar 15 '11 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.