2

I have a laptop HP PAVILION dv6-3126er with Windows 7 Home Edition installed. Neither the control copy nor the control paste work (i've tried: Ctrl+c, Ctrl+v, Shift+c, Shift+v, Ctrl+Insert, Shift+Insert). I've tried to run a system check through CMD with sfc /scannow. It repaired something, but when I restarted it didn't solve the problem.

I've also tried many key combinations (like Alt+Ctrl+fn), but nothing works in any program. In Microsoft Word 2003, in the menu, I have no key combination for copy/paste near them (in my previous computer they've been there - in brackets). Shift+Delete works by the way.

I bought this laptop a few weeks ago, and I discovered this problem within the first days. I have no viruses because I have had no time to even connect it to Internet. Anyways, I checked it for viruses and it is clean. I don't want to do a system restore, because I see no reason to do it for a pretty clean system.

I hope it is not a problem with the laptop itself. Maybe there is another reason. Maybe i need to do some more system checks. Any suggestions?

5

Does it happen constantly and consistently? That is, does it happen every time you boot and occur from startup to shutdown or does work sometimes?

If it works sometimes, then when it doesn’t, do you happen to have a browser open? If so, do you have some websites that you open regularly?

I ask because there exist programs (especially Flash applets) that copy an empty string to the clipboard in a loop in order to disable copying or pasting. I first discovered this on a web-survey site, but they also exist on other pages in an attempt to prevent users from copying content; however they also block copy/paste from working on the whole system until the applet is killed! (Yes, it’s not very effective copy-protection and incredibly intrusive and sucks CPU cycles, but… um, that’s it.)

What you can try is to view the clipboard to see what happens when you try to copy something. Windows 7 does not have the clipboard viewer (which was limited anyway), so get ClipSpy, then try copying various things to see if they end up in ClipSpy. Try copying some text, copying graphics (press PrintScreen to capture the screen), and try copying some files/folders. Do they show up in ClipSpy? Does the Paste option become available or does it remain grayed? By running these tests, we can narrow down what the problem is.

  • Ctrl+C and Ctrl + V suddenly started to work after i ran the GetOpenClipboard program which didn't show any errors with the clipboard. But Ctrl Insert and Shift Insert still don't work. – Guest Mar 16 '11 at 15:49
  • Does Insert work at all? Try toggling overwrite in Wordpad to see if it works. – Synetech Mar 16 '11 at 18:16
  • no, it doesn't work. – Guest Mar 16 '11 at 18:23
  • by the way, in my laptop insert and print screen is one button. I have here - ins and prt sc together. – Guest Mar 16 '11 at 18:28
  • So? You should be able to press them separately using the Fn key. Does your laptop have a “function lock” key that alters what the keys do? Run ClipSpy and see what happens when you press the Ins/PrtScr key by itself. See what happens when you press it while holding Fn. – Synetech Mar 16 '11 at 18:33
2

Did you try using On Screen Keyboard

  1. Press windows key + R
  2. Type OSK and press enter
  3. Try using your key combinations and see if it works or not ?
1

This is an old thread but I'm sharing my simple solution for others. I have SmartRam from Advanced System Care started and just exiting this program solved it for me.

Edit: Other forum has a better solution - Just disable the 'Clean clipboard' option for SmartRam.

0

I have another solution. Perhaps the cut-paste problem is application specific. I couldn't for the life of me figure out why cut-paste wasn't working in Win Explorer. I closed Windows Explorer and re-opened. Problem solved!

0

Close the page/tab you are trying to copy & paste to and open another fresh one .I had this problem when I occidentally moved the actual page on top of the page I was trying to copy and paste some info; to so closed it opened a new one and it worked .

0

I had these problems suddenly occur for apparently no reason on my HP 6560b Notebook. CTRL+C deleted selected text, CTRL+X bringing up save options menu, LH Shift key not working, RH Shift works but sometimes adds additional characters.

Removed Windows updates that occurred on 06-09-17: • KB4034670 • KB4019990 • KB4033996 Leaving me 397 windows updates installed. This made no difference. I had already had a recent McAffee scan I used MS Widows Defender and ran that I used MS Malicious Software Removal Tool (MSRT) this scanned about 4million files and took about 6hours and all of these found absolutely nothing.

Downloaded NEW version of Synaptics Mouse-keyboard driver software: v17.0.19 (previously was v 17.0.18.25) This made things worse and I could not get numerals to work even from numeric pad. Also sometimes had to use CAPS lock to log in: this was getting seriously worrying

So last resort I changed the keyboard from a 6570 laptop (very similar HP Notebook) and Bingo it worked OK. Apart from keyboard orange light ion top LH corner of the Touchpad. Could not deselect the touch pad by double touching it. This occurred after downloading the later version of Synaptics driver. Also get a weird beep noise when using CTRl+C sometimes. I will try reverting to my original Synaptics driver but I'm not to fussed with these issues. Who would believe such strange symptoms could result from a hardware fault. And yes i do look after my laptop very well and nothing was spilled on the keyboard and it had only 2years of light use. Hope this helps.

-1

ya i no this an old thread: but just want to offer my meaningful advice, try using IOBIT system care 6 i was having same problem with my toshiba satellite 32-bit win7 ultimate still found a forum that gave me this treat and it work. good luck .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.