2

When I run GTK applications on KDE, they use the QtCurve theme that matches my color and font scheme as configured in the KDE System Settings application.

However GTK applications run as superuser use the old default GNOME, regardless of whether I run them with kdesudo, gksudo, or sudo on a terminal. For example, here's gedit run as superuser on top, and under my normal user account on the bottom: gedit run as superuser and normal user on KDE

Strangely, Qt applications run with kdesudo display the default Oxygen styling but use my settings when run with sudo on a terminal.

Is there any way to configure the stying GTK applications use when run as superuser on KDE?

4

Try this.

Create a ~root/.gtkrc-2.0 with contents:

gtk-theme-name = "QtCurve"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.