I'm not sure what I did to cause this, but every time I log in to Ubuntu it tells me that "User's $HOME/.dmrc file is being ignored." The message goes on to suggest that it is probably a permissions problem. However, my .dmrc file is owned by the correct user, and that user has read, write, and execute permissions on the file. What can I do to fix this?

  • Have a look at this - ubuntuforums.org/showthread.php?t=758126
    – user4358
    Aug 19, 2009 at 15:47
  • What does ls -l display from /home/
    – Gren
    Aug 19, 2009 at 15:47
  • @Gren: Every result returned with ls -l shows the correct user as the owner, with at least rw permissions for the owner. When I run ls -al, .dbus and .wireshark are owned by root.
    – DLH
    Aug 19, 2009 at 17:38

1 Answer 1


Try getting rid off the execute permission:

chmod -x .dmrc

If that doesn't work, try making the file only readable by yourself:

chmod go-rw .dmrc

Another Edit:

After Googling around for a bit, it seems that the permissions on your home directory might also be a factor. What is the output of ls -dl $HOME on your system?

  • Didn't work, even though the permissions for that file are now -rw-r--r--.
    – DLH
    Aug 19, 2009 at 17:34
  • Ah! My .dmrc is only readable by myself. I've change my answer accordingly.
    – innaM
    Aug 19, 2009 at 18:57
  • Sorry, I didn't see your edit until now. My .dmrc permissions are now -rw-------, but it still doesn't seem to make a difference.
    – DLH
    Aug 24, 2009 at 14:43
  • Wow. What a stubborn beast gdm seems to be. I've edited my answer once again.
    – innaM
    Aug 24, 2009 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.