6

I must have done something to Google Chrome on my Mac.

Local HTML files, even though they are associated with Chrome, do not actually open in Chrome anymore when I double click them. For example, double clicking an HTML file on my desktop will launch Chrome, but the browser window will not display the content of the HTML file.

If I change the program my computer will use to display HTML files to Safari or Firefox, they open as I expect them to, rendering the HTML properly in a browser window.

If, I have a Chrome window open and drag the HTML file into the browser window, it will render the HTML content properly, but the double clicking is the behavior I'm hoping to get back.

Does anyone know why this might have caused this change in Chrome behavior? And best of all, how to fix it?

Chrome extensions I use: LastPass, Xmarks, Google Voice.

migrated from stackoverflow.com Mar 15 '11 at 10:37

This question came from our site for professional and enthusiast programmers.

  • -1 You write "If, I have a Chrome window open and drag the HTML file into the browser window, it will render the HTML content properly" <-- That contradicts your title that says "Google Chrome no longer opens local HTML files". So your issue is one of file associations. I may improve your title – barlop May 2 '15 at 21:40
2

The OS assumes that a file association just means "appname" "filename.ext". If for some reason the people over at Google screwed that up somewhere that would be a reason why it stopped working

2

This seems to be a bug in Chrome, it's been reported to Google, so we can just sit and wait for them to fix it. No workaround at the moment that I know of...

2

I fixed this by changing default 'open with' option on the Mac from Chrome to Firefox and then putting it back to Chrome.

1

I've managed to partially get around this (OSX, Chrome v 42.0.2311.90) by realizing that the files I'm aiming to load are in my Sites folder, and I have the built-in Apache server enabled, so I just navigated to it via its localhost URL: http://localhost/ndic/wpboom_design/site_settings.html

I tried using Firefox in the interim, but each browser's developer console is really different and I couldn't get used to it. Anyway this workaround will help me make do for now.

0

I have an perfect answer.

For Mac:

Goto Text Edit > Preferences. Then under 'New Document', select 'Plain text'. And under 'Open and save', Check both 'Display html file as html code' and 'Display RTF file as RTF code'. Uncheck 'Add ".txt" ' option.

Then save your html code in TextEdit in .html format.

This should work for Chrome and Safari.

  • I came here with the same problem, my .html file was created in TextEdit, the command-line file command shows it as html, the suffix is .html, and Chrome still displays the raw text. – arp Jan 1 '18 at 19:09
0

Old question, but...

There is a Chrome extension called Enable local file links (Chrome web store, repository on Github), which is still pretty secure (e.g. a page cannot open a local file except in response to a user interaction).

Install it, restart Chrome and open local files by double-clicking!

-2

Look if ask.com or another search engine is active in the browser. This causes that Chrome starts with the default page. Even IE 10 or 11 doesn't open an html or htm file. It will only start the Internet browser. Disable the add on applications like ask.com ect.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy