My MediaCenter (running Windows 7 x64) has me puzzled. I've started seeing really slow upload speeds from the computer - so slow that the Xbox 360 won't connect anymore.

I've tried two "internet speed tests" and they all give my about 50 Mbit download and aprox. 1 Mbit upload (I have 50/50 Mbit fiber connection).

My setup looks like this: Fiberbox -> Router -> Switch -> Computer/Xbox 360/Printer etc.

That is, everything is connected to the switch, which is a 1000/100/10 Mbit device from 3Com. If I plug the computer directly into the router (which has 4 ports) I get the upload speed I want. This led me to buy a new switch (from D-Link which also is a 1000/100/10 Mbit device). However the problem remains the same!

If I hook up my laptop to the switch there's also no upload speed problems, so I've concluded it must a problem with the MediaCenter?

One final note, however! I've tried using a old 100/10 Mbit switch from 3Com instead of any of the GBit switch and that works just fine (ie. upload speed is as expected...)

Any help on this would be great :)


Just a thought, swap out the ethernet cables you're using (or use a tester on them).

A cable that works fine for 100MB may not be up to snuff for 1000MB, and start throwing so many errors that it slows things down to a crawl.

Or, who knows, maybe your switch is bad?

Just some things to think of/try.

| improve this answer | |
  • I've tried switching the cable to the one that works fine with my laptop, but that doesn't help. I've tried to different 3Com Gbit switches and 2 different D-Link Gbit switches without any improvement, so I don't think that's the problem - otherwise I'm having incredibly bad luck with switches :) – Kenneth Kryger Sørensen Mar 16 '11 at 7:21

Turned out to be a motherboard issue I think. I tried disabling the onboard NIC and plugged in another Gbit NIC in the PCI slot with the same result. Now I've switched motherboard (and CPU + RAM) and everyting works fine. Same hard drive, cable, and even same installation of Windows 7 - didn't format the hard drive - just booted up the computer with the new hardware...

| improve this answer | |

Perhaps the NIC driver is an issue with 1000Mb speeds. Is the router only 10/100? That would explain why it works there but not with the 10/100/1000. You could try strapping the port and NIC to 100Mb.

| improve this answer | |
  • The router is 10/100 only. How do I strap the port and NIC to 100 Mbit? That sounds like something I should give a try... – Kenneth Kryger Sørensen Mar 16 '11 at 7:22
  • Sorry for the delay. In windows go to the Device Manager and look at the properties for the network card. Set it to 100 full duplex. Make the same change to your switch or it could get worse. – uSlackr Apr 15 '11 at 0:55

I had a similar issue (nvidia on-board nic) until I disabled interrupt moderation and set flow control to receive only. I think in my case too many things (router, os, nic driver) were trying to control the flow.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.