While trying to install *.msi or file on a windows 7 operating system I got the following error:

error 1325 <username> is not a valid short File Name

How can I fix this issue so the install will go through?

migrated from stackoverflow.com Mar 16 '11 at 9:29

This question came from our site for professional and enthusiast programmers.

  • What is the username in question? (If you prefer to remain anonymous, does it have any characters that aren't ASCII?) – David Yaw Mar 14 '11 at 22:07
  • The username is any ASCII username. In this case it will be any username over 8 characters – Whitecat Mar 14 '11 at 22:11

This happens on file that is within a domain. From what I have seen so far this only happens with users that log in from a domain.

This solution is simple go to the following registry location in regedit:

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/User Shell Folders

Here you should change the personal registry key:

  • from \\<domain>\profiles$\<username>
  • to %USERPROFILE%\<username>

Note that User Shell Folders may exist in other locations as well, so you can search in the registry editor for User Shell Folders and correct all values you find, depending on your personal installation.

Then try to reinstall the program.

Another option is to create a new Admin User on your computer and install it that way.

  • Can confirm this solves the issue. – Brock Vond May 25 '18 at 3:18

To the original poster of this question, this fixes more than just .Net

I was fighting the same error installing AutoCAD, in an environment of GP's and Roaming profiles with locked out Local Admin accounts. (We are also in the process of migrating to Win7 from XP and having to install/test software) At one point months back I had to go into several registry profiles and hardcode the UserShellFolder because the prior Admin had created a Default User profile based on his profile which, of course, screwed up the pointers to the Personal settings and made it point to his User profile anytime a new user profile was created.

Also, you may need go into the Shell Folders in the same Explorer folder as mentioned above and tweak the profile references there too.

  • 1
    I found out this was the issue with installing any file actually. – Whitecat May 30 '12 at 3:37

I had the same problem with the ArcGIS program and so I went back and looked at the Google forums in order to help someone :) I spent two days trying various ways to solve, including editing the registry values. I had uninstalled the program, but I think they were files that were not deleted.

I solved my problem with the program "Revo Uninstaller" (Free) by following these steps:

  • In the list of programs available for uninstallation, ArcMap (ArcGIS) was not showing up, but clicking the "Forced Uninstall" icon appears a field to enter the name.
  • I typed "Arc" and the program has appeared on the list.
  • I selected "Advanced" and "Next".
  • I selected all and deleted.
  • I clicked "Next" and finished.

After that, I managed to reinstall the program without any problem.

  • The question is asking for when a program is being installed and not updated. – Whitecat Dec 2 '15 at 21:32

We had the same issue with AutoCad 2013. Normally our user names are eight characters but occasionally have one with more which is why we did not see the problem originally.

We do not use Roaming Profiles but do redirect all user files (Documents, Pictures, Videos, etc.) to network file storage. Our GPOs move this to the same as the user's home directory in AD.

For us, changing the "Personal" value in the key set mentioned above allowed the first run of AutoCad to proceed normally.

Note, however, that this also puts the user's "Documents" folder back to the C:\Users\\Documents folder instead of the desired network storage. After the first run of AutoCad completes we had to put the registry value back to its original setting; have the user log off and back on again.

AutoCad should still work at this point.


None of the suggestions here worked for me. I decided to login to the PC as network supervisor and run the update (for all users on this PC) and that did the trick.

It is apparent that somehow the regualr User's profile must be damaged. I had spent considerable time digging in the haystack of the registry attempting to locate the problem when I decided to cut my losses and attempt the heavy hand approach. It worked but the rationale for failure as the User still alludes me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.