19

Thunar is my main file manager. Normally it automatically creates thumbnail images of all images in the directory being viewed. After experimenting with other Linux distros then installing Arch Linux once and for all, Thunar is not showing thumbs. Image files all get the same generic image icon.

Googling turned up some information:

  • Something called gvfs needs to be installed. I have it. Still no go. (Apparently this isn't actually needed anyway.)
  • Someone had this problem and fixed it by running some mime-related command (I didn't save any notes) I did this same command but no go.
  • Checking the obvious: in Thunar's Edit/Preferences, yes, the [x] Show thumbnails is turned on.

When I view one image in GIMP or EOG, the generic icon in Thunar is replaced by a thumbnail. But only for that one file I opened.

  • It now occurs to me that there's a unix/linux SE site. Is there an easy no-brainer way to transfer this question over there? – DarenW Mar 18 '11 at 2:53
33

A package called tumbler is needed for thunar to automatically generate thumbnails.

| improve this answer | |
  • This is strange, I never needed tumbler when I used Thunar :/ – user1686 Mar 19 '11 at 16:25
  • 6
    For me, tumbler-plugins-extra did the trick on a Debian system. – hochl Feb 17 '16 at 0:00
  • 2
    For me, sudo pacman -S tumbler did the trick on a Manjaro system. – ILikeTurtles Jul 4 '18 at 12:16
2

I had to "chown -R *username* ~/.thumbnails" obviously replacing username with your user name. This immediately fixed my problem.

Root was the owner of .thumbnails. I found this by opening GIMP and it gave an error that it could not gain access to .thumbnails, but, if GIMP isn’t giving you this error this may not be the solution for you.

| improve this answer | |
2

Even if you installed thumblerd you may not see thumbnails for remote storage, including MTP (new Android devices). Check your file manager's settings, e.g. for Thunar one have to set "Show thumbnails: always" (not "Only local files").

| improve this answer | |
1

Removing configuration in Ubuntu helped me show thumbnails in thunar again:
mv ~/.config/Thunar ~/.config/Thunar.bak

| improve this answer | |
1

I had to run thunar -qin the terminal to make it use ffmpegthumbnailer, from the man page:

-q, --quit Terminate any Thunar instance running in the background (spawned using the --daemon option). This command should be used whenever Thunar is upgraded to a new version to ensure that no old instance is reused.

| improve this answer | |
  • I am confused. Why would the quit option make it use ffmpegthumbnailer? – phil294 May 16 '18 at 3:21
  • @Blauhirn Thunar usually runs as a daemon, and won't automatically start using ffmpegthumbnailer as it's not looking for it while it's running. E.g. if you install ffmpegthumbnailer after thunar was started then it won't use it, but after a thunar -q it starts using it. – ZN13 May 16 '18 at 7:14
0

I had to re-install tumbler (xubuntu 14.04). ( ~/.thumbnails was empty after I restored the system from a rsync-backup that had omitted thumbnail-data)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.