I am trying to upgrade the 250GB hard drive in my MacBook Pro (early 2008 model) to a 750GB drive. I have connected the new drive via an external USB enclosure. The drive is recognized fine, I can format it, etc.

However, every time I try to clone the drive, I am getting Input/Output errors. Before the clone operation, I have verified both the internal and the external drive using Disk Utility, and they both check out fine. After the clone operation, the external drive shows multiple "Invalid node structure" errors:

Disk Utility errors

I have tried two approaches for cloning the drive:

  1. Using Disk Utility, by starting from the OSX install DVD
  2. Using Carbon Copy Cloner

The outcome is the same in both cases.

The Carbon Copy Cloner logs show a handful of the following types of errors:

rsync: mkstemp "<... an external filename ...>" failed: Input/output error (5)
rsync: stat "<... an external filename ...>" failed: Input/output error (5)

The actual files affected seem to be different across different runs of the application.

Before the last run, I used Disk Utility to (once more) reformat the external drive and explicitly overwrite it with zeros, but this made no difference.

I also tried running a surface scan in Tech Tool Pro overnight. It got about 2/3 of the way through before I had to disconnect the drive (had to take my MacBook Pro to work), but so far it didn't report any bad blocks. Assuming it scans the drive in the same order in which blocks would be allocated during actual use, it seems like if bad blocks were to blame for the clone failures, they should have been found already (given that the source drive is only 250GB).

As a last attempt, I may try SuperDuper as well, although my understanding is that it uses the same underlying rsync approach as Carbon Copy Cloner, so it's unlikely to perform any better.

Are there any other things I should try before I send the drive in for a replacement? Could these problems be caused by my internal drive, even though it works fine and checks out fine in Disk Utility?


Usually when we see "mkstemp" errors, they are due to filesystem, media, or hardware problems. In this case, it's pretty clear that your destination disk is failing. If it is brand new, get it replaced under warranty. If you have any other questions/concerns, don't hesitate to drop a note at my Help Desk, help.bombich.com.


  • Thanks for the feedback! I bought the drive from Amazon last week, so replacing it should be painless. I'll do that first, and then will definitely try again with Carbon Copy Cloner. – Mirko Froehlich Mar 18 '11 at 16:20
  • Sure enough, getting a new drive fixed the problem. I cloned it with Carbon Copy Cloner and it works beautifully. :) – Mirko Froehlich Mar 21 '11 at 14:29

last time I saw funkiness with rsync on my machine it was because my $PATH picked up rsync delivered with the OS in /usr/bin as opposed to rsync from macports in /opt/local. However, that might not help you because CCC brings it's own rsync in the app bundle...

Now before you declare the drive dead: can you try with ditto(1) ?

  • Sure, I'll give that a try. Thanks for the suggestion. – Mirko Froehlich Mar 18 '11 at 4:48
  • err, something that came to later today, and forgive my asking: on which disk did you see the errors? On the external cloning target? Or on the source disk? – Florenz Kley Mar 18 '11 at 13:40
  • The errors occur on the destination disk, which definitely points to an issue on that drive. The weird thing is that zero-ing out the drive didn't result in any errors. I have not tried ditto yet, but I ended up giving SuperDuper a try as well, with the same results. I think I'll just replace the drive (under warranty) for now and try again. – Mirko Froehlich Mar 18 '11 at 16:19
  • that sure sounds strange. (could you maybe post the complete log entry?) EDIT: forget the investigation... as much as I hate to not establish root cause, maybe it's a better use of time to just get another disk. – Florenz Kley Mar 18 '11 at 16:25
  • Yes, that's what I did. Sure enough, getting a new drive fixed the problem. Thanks for your suggestions. – Mirko Froehlich Mar 21 '11 at 14:28


Forgive me for asking something obvious but do you have another drive to test with? If you do maybe try that drive in the enclosure to ensure the enclosure is functioning properly. If it's a new drive it's most likely fine...but I have received bad drives out of the box. If CCC and Disk Utility are throwing I/O errors you have a larger problem than your method.

Another possibility is just get a time machine backup to an external drive and then restore it to the drive your upgrading to.

Good Luck.

  • Thanks for the suggestion. Unfortunately I don't have another drive to test with that's large enough. But it is starting to look more and more like the new drive is to blame. It's under warranty, so I'll go ahead and replace it. – Mirko Froehlich Mar 18 '11 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.