5

My friend asked me to look at her Acer Aspire laptop with Vista Home Premium as it is no longer playing DVDs. I found that Windows Media Player would not launch. I found this thread, which contained a number of suggestions, none of which solved the problem. Here is what I tried:

  • Tried running WMP via desktop shortcut, QuickLaunch bar or going to Program Files\Windows Media Player\wmplayer.exe. In all cases, wmplayer would launch then terminate immediately (verified through the Processes tab in Task Manager).
  • Tried running wmplayer.exe as Administrator. The UAC dialog would come up, I'd approve, then wmplayer would launch and terminate immediately.
  • Uninstalled all non-Microsoft media programs except RealPlayer, iTunes, QuickTime, Acer Arcade (the laptop owner uses all those apps).
  • Tried running Program Files\Windows Media Player\setup_wm.exe as Administrator, it launched but said that a newer version of WMP was already installed.
  • Deleted the "Windows Media" folder located under %userprofile%\appdata\local\Microsoft then tried starting WMP - wmplayer would launch and terminate immediately.
  • Register wmp.dll by typing "regsvr32 wmp.dll" in an Administrator cmd window then tried starting WMP - wmplayer would launch and terminate immediately.
  • Run "SFC /SCANFILE" in an Administrator cmd window - get an error message that it found invalid system files and could not fix them, so look at the log file cbs.log. The log file shows that there are broken files associated with Windows Sidebar (which the user does not use) but none relating to WMP.
  • Log off to safe mode and run "SFC /SCANFILE" in an Administrator cmd window again - same results.
  • Try to download and install XP WMP - the microsoft.com site recognizes the OS as Genuine and allows the download, but when I launch the installer it says the system is not Genuine. Clicking the link directs me back to IE where I can authenticate the system as Genuine. The installer still fails to recognize the system as Genuine. It is a Genuine Vista installation.
  • Try to run this update (KB931621). The installer said it did not apply to the system.
  • Set Windows Media Player as default in Program Access and Defaults. Same results.
  • Tried running "for %a in (%systemroot%\system32\wm*.dll) do regsvr32 /s %a" in an Administrator cmd window - same results.
  • Went to this Knowledge Base article (947541) and ran the Microsoft Fix It. The Fix It ran successfully, but WMP would still launch and terminate immediately.
  • Multiple reboots in the process of doing all of these steps.
  • After all this, looked in the Application and Security logs. No events pertaining to WMP were logged.

The computer was preinstalled with Vista Home Premium and I have the Acer backup DVDs which will reimage the drive. I do not have Vista install DVDs. Reimaging the system is not an option. I'd also rather not restore the system to an earlier point unless it's absolutely necessary.

What else can I do to repair or reinstall WMP?

  • Is this a 64bit version of Vista or 32bit? – DGivens Aug 19 '09 at 17:46
  • Vista Home Premium 32-bit. – rpm1200 Aug 19 '09 at 17:47
  • Using WMP11 or 12? – DGivens Aug 19 '09 at 17:58
  • You might try installing WMP12 to see what it does for you. Basically you'll be taking a copy of WMP12 from Windows 7 and putting it on there. There's several "how-to's" if you look around. – DGivens Aug 19 '09 at 21:34
1

Just try this Microsoft tool first. This worked for me just now...

http://support2.microsoft.com/mats/windows_media_player_diagnostic/

  • 1
    Please quote the essential parts of the answer from the reference link, as the answer can become invalid if the linked page changes or the target site is unreachable/permanently offline. – DavidPostill Nov 26 '14 at 16:58
0

You can uninstall Windows media player and then run windows update. The updates will install a fresh copy. Make sure you reboot in between and it might take a few searches for updates before it comes up.

  • WMP does not appear in the Programs list. How do I go about uninstalling it? – rpm1200 Aug 19 '09 at 19:30
  • 1
    You could try using Revo Uninstaller. I've been quite pleased with it. revouninstaller.com – Travis Northcutt Aug 19 '09 at 21:46
  • 1
    Open up the control panel and go to add and remove programs. Click on windows components and scroll down until you see windows media player. Uncheck the box let the uninstall take place and reboot. reverse the process to install it back in or run updates. – NycLifeG Aug 20 '09 at 13:39
  • I already looked there, it does not appear in the Windows Components list. I'll try Revo and see what it does. – rpm1200 Aug 20 '09 at 20:31
  • It does not show up in Revo Uninstaller at all, not in Uninstaller and not in Tools \ Windows Tools \ Add/Remove Windows Components. – rpm1200 Sep 13 '09 at 18:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.