My harrowing experience over the past 24 hours:

  1. Windows 7 installation hosed after bluetooth driver install.
  2. Attempting to recover using restore points via "Repair" on the bootable Windows 7 installation CD.
  3. Attempting to go back one day in the restore points. No joy.
  4. Attempting to go back two days in the restore points. No joy.
  5. Attempting to go back one week in the restore points.
  6. Still no joy. Windows won't boot. Apparently something is REALLY hosed.

And then it hits me -

  1. PANIC - the restore points somehow reverted DATA files to their older versions! Word, Powerpoint, SPSS, etc document versions are all one week old now.
  2. Using the "freshest" restore point.
  3. Failed to restore yesterday's restore point!!!
  4. I am stuck at old versions of the data!!!
  5. Booting KNOPPIX, mounting NTFS partition as read-only under KNOPPIX. Checking.
  6. Nope, the data files are still the one week old versions.
  7. Booting Windows 7 CD, Recovery console - Cmd prompt - navigating - yep, data files are still one week old.
  8. Removing the drive, mounting it under other Windows 7 installation.
  9. Still old data.
  10. Running NTFS undelete on the drive (read-only scan), searching for file created yesterday.
  11. Not found.


At this point, idea: I will install a brand new Windows installation, keeping the old one in Windows.old (default behaviour of Windows installs).

I boot the new install, I go to my C:\Data\ folder, I choose "Restore previous versions", click on yesterday's date, and click open...

YES! It works!

I can see the latest versions of my files (e.g. from yesterday).

And then, I try to view the files under the "yesterday snapshot-version" of C:\Users\MyAccount\Desktop...

And I get Permission Denied as soon as I try to open Users\MyAccount. I make sure I am an administrator. No go.

Apparently, the new Windows installation does not have access to read the "NTFS snapshots" or "Volume Shadow Snapshots" of my old Windows account!

Cross-installation permissions?
I need to somehow tell the new Windows install that I am the same "old" user... So that I will be able to access the Users\MyAccount folder of the snapshot of my old user account.


EDIT: Thank you, Kyle - you saved me!

  1. I opened an elevated cmd prompt (I.e. Right click/Run as admin)
  2. Typed: "net user administrator /active:yes"
  3. Logged out and logged back in as admin.
  4. The user folders in the snapshots were then accessible.
  • 1
    What version of 7? I have never had a problem changing permissions as the built in admin account. open an elevated cmd (right click run as admin) type: net user administrator /active:yes then log out and log back in as admin. Mar 18, 2011 at 19:01
  • You rule, mate! Thanks so much! Can you add your suggestion as an answer so I can click on the check mark?
    – ttsiodras
    Mar 18, 2011 at 19:12
  • Of course, give me one second and I will add it. Mar 18, 2011 at 19:13

4 Answers 4


Per OP's request I am adding my comment as an answer:

I have never had a problem changing permissions as the built in administrator account. open an elevated cmd (right click run as admin) type: net user administrator /active:yes then log out and log back in as administrator.


You're not going to be able to "impersonate" the old user - when you reinstalled, you got a new randomly generated GUID/SID. However, you may be able to explore the old previous versions if you take ownership (and adjust permissions so you have full control) of everything in System Volume Information and the old Windows folders.


Change the permissions on the "Users" folder you backed up.


  • I am assuming you refer to Windows.old\Users\MyAccount. I tried it, giving Everyone full control, but the permissions of the corresponding folder in the snapshot are still the old ones. i.e. I still get access denied when trying to read the the snapshot version of the folder. Note that I also tried creating the same account name with the same password in the new installation - I still get access denied for the snapshot folder (of the identically named "old windows" account)
    – ttsiodras
    Mar 18, 2011 at 16:40

You also have to make sure it is not inheriting permissions from lower level folders. You'll need to seize ownership of the folder, and uncheck the inherit properties. Even if you explicitly give permissions to yourself, an inherited explicit deny permission will override that permission.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .