I'm attempting to setup an Ubuntu 10.10 box so that anyone can connect to port 5900 and be greeted by the gdm login manager. To do so, I added a vnc entry in /etc/services and I am starting Xvnc4 using this xinetd config file:

service vnc
  protocol = tcp
  socket_type = stream
  wait = no
  user = nobody
  server = /usr/bin/Xvnc
  server_args = -geometry 1000x700 -depth 24 -broadcast -inetd -once -securitytypes None

This kind of works...I can start multiple sessions all to port 5900, and I get an X screen. The problem is that I only get an empty, gray X screen with no applications started.

I know when you run vncserver from the command line it will look to your ~/.vnc/ directory for your passwd and xstartup files, and I think what I want to do is put "gnome-session" into the xstart file. However, which xstartup file? The running user is "nobody" who obviously doesn't have a ~/.vnc/ directory. I tried a /root/.vnc/xstartup file and a ~scott/.vnc/xstartup file and it doesn't look like they were even read.

I changed the xinetd vnc service so that it would "strace" Xvnc4. I looked thru all the "open" lines and didn't get a clue as to what file it was trying to read for xstart.

Can anyone help? I just want a terminal server where the user is presented with a gdm login screen.


2 Answers 2


Well, I had just been writing a nice methodology for you on how to do it with the default setup, only to find a little note in https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes when looking into turning on XDMCP (which you will have to do for what you want) that says:

Ubuntu 10.10 does not support the XDMCP protocol for remote graphical logins. Users who require XDMCP support will need to install another display manager, such as wdm or xdm, for this functionality.

So that kind of scuppers your nice graphical login. You will have to replace gdm with something else like xdm or maybe kdm or wdm instead. That way you can enable XDMCP and the -broadcast flag of the Xnest will be able to find the X server.


I finally gave up on this, started fresh from a snapshot of my system, and installed xrdp and vnc4server. Worked right out of the box. Very frustrating. I will be trying VNC again when 11.04 comes out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .