6

I'm running a FreeBSD 8.2 server with GIT 1.7.4.1

Attempting to clone anything, like

$ git clone https://github.com/joyent/node.git node

ends up, quickly, giving me this

Cloning into node...

and the only thing in the directory is this file

$ git-remote-https.core

(My above example is for node.js, but I get the same results for anything on GitHub)
Any clues as to why the repo isn't being cloned for me?? No error messages, just that file, which I have no idea what it is

8

git-remote-https.core is the memory of the git-remote-https process at the time it crashed. Yes, it crashed. Why is anybody's guess.

I would suggest recompiling GIT from ports and trying that. If it still crashes then I would recommend recompiling from ports but with gdb enabled, then you can use gdb to examine the core dump (as that file is known) to see where and why it crashed.

It may be an incompatibility between library versions, in which case compiling from ports usually fixes it, or it may be something more serious.

| improve this answer | |
6

Upgrading curl and openssl fixed the issue for me.

| improve this answer | |
4

If this starts happening immediately after a portupgrade -a or equivalent that upgraded git or openssl, try recompiling libcurl (e.g. portupgrade -f curl).

| improve this answer | |
0

No need to guess check on core: http://www.freebsd.org/doc/en/books/developers-handbook/debugging.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.