I wanted to auto-mount my ntfs drives on boot time, so I went through this article to do so using pysdm.

I followed this article auto-mount-your-ntfs-partition-in-ubuntu.

  1. But when I tried to uncheck the box Mount file system in read only mode, It didn't work. It was checked again, on its own. The drives were also mounted not by the user names, but by the names sda3, sda5 etc.

  2. In the option for the specifying the name for the ntfs drives, i specified my own names, the names by which the drives were usually mounted.

I didn't try to uninstall the package, as I thought that might be harmful and could be fatal.

Now, when I restarted my Ubuntu, it just doesn't restart.
It stays in an infinite loop, i guess and even the login screen doesn't showup.

Please help me, and if something is not clear in the question, let me know. Suggest any possible way, I can get my Ubuntu (10.04) back and running, with my packages as they were configured.

EDITED: I ran Ubuntu in the recovery mode, and it showed the following output on the console twice and then went off to the same ubuntu logo as earlier on.

Console output in recovery mode

The error that I can see is that I incidently typed the mount location of a drive to /sda/Silver Spoon and that is causing trouble.

  • What does show up? What's the last few lines on the console?
    – Majenko
    Mar 21 '11 at 10:33
  • @Matt: There is no console, the ubuntu icon in the middle shows up, till the login screen shows up. But in this case, the login screen doesn't show up Mar 21 '11 at 10:57
  • pressing Esc as soon as the Ubuntu logo appears will remove the Ubuntu logo and display the console.
    – Majenko
    Mar 21 '11 at 11:03

Boot from a Linux CD. Mount your root partition on /mnt, then fix the error in /mnt/etc/fstab. (I think you can use /media/Silver\040Spoon.)

  • By doing so, my data, applications and packages won't get removed??? I don't know much about all this, so don't mind. Mar 21 '11 at 14:49
  • @Jatin: Why would they be? You are only editing a file to remove something you added yourself.
    – user1686
    Mar 21 '11 at 15:07
  • I am sorry but I still don't understand. Lets say I am an amateur. When I install Ubuntu using the Linux CD, and when it asks to specify the mount partition on /mnt (which I had previously specified to be / when I first installed Ubuntu), and I install it, won't it overwrite previously installed Ubuntu??? When do i edit the file and how?? Mar 21 '11 at 15:34
  • @Jatin: I said only boot, not install. Just insert the CD and reboot, and it should boot into a working Ubuntu system that's entirely in-memory. Use it to fix the on-disk one.
    – user1686
    Mar 21 '11 at 16:41
  • Thanks. It worked. However I am stuck with another problem [ Ubuntu auto-mounts ntfs drives in Read-Only Mode](superuser.com/q/261275/70791). Can you help me here as well. Mar 23 '11 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.