At some point, I had tried to install and use 'SCPlugin' on Mac OS 10.6 but found that it wasn't what I needed.

According to the installation doc, it said to remove the .plugin file from these locations:

  • /Library/Contextual Menu Items/SCFinderPlugin.plugin
  • /Library/Receipts/SCPlugin.pkg
  • /Applications/SCToolbarButton
  • /usr/local/bin/svn (if you installed the optional links)

But months after uninstall, I'm still seeing errors reported my console:

com.apple.launchd.peruser.501[93]   (org.tigris.scplugin.launch[29882])  Exited with exit code: 1
com.apple.launchd.peruser.501[93]   (org.tigris.scplugin.launch)         Throttling respawn: Will start in 10 seconds
com.apple.launchd.peruser.501[93]   (org.tigris.scplugin.launch[29883])  posix_spawn("/Library/Contextual Menu Items/SCFinderPlugin.plugin/Contents/Resources/SCPluginUIDaemon.app/Contents/MacOS/SCPluginUIDaemon", ...): No such file or directory
com.apple.launchd.peruser.501[93]   (org.tigris.scplugin.launch[29883])  Exited with exit code: 1

I did a system-wide search for scplugin and nothing is reported. How do I ensure that that launchd isn't trying to launch the plugin?

  • Just as a comment, I never installed SCPlugin, yet I had this same error message in my Console. So I guess that some app (probably a GUI client like Versions or Cornerstone) installs this launch job by default. – julien_c Jan 30 '12 at 15:10

You can temporarily stop launchd from trying to start that program by entering the following command in a Terminal window:

launchctl remove org.tigris.scplugin.launch

The effect is only temporary because the control file that defines when and how to launch that program still exists and launchd will read it again after your next login. You will need to find and delete that file to make the change permanent.

The filename is usually the launchd label1 with .plist added to the end. Since I could not be sure of the name or location2 of the launchd file, I downloaded and examined the installable package for SCPlugin. It turns out that its file follows the naming convention. The full pathname is /Library/LaunchAgents/org.tigris.scplugin.launch.plist.

You should be able to use Finder to delete the file. Open a new Finder window and navigate to that directory (or press ⌘⇧G, type/paste /Library/LaunchAgents/, and click Go), then delete the file (drag it to the Trash or press ⌘⌫; you may need to type your passwword).

1 The label is an identifier that launchd uses. The console messages from launchd show the label in question: org.tigris.scplugin.launch.

2 launchd looks for files in several directories:

  • ~/Library/LaunchAgents/
  • /Library/LaunchAgents/
  • /Library/LaunchDaemons/
  • /System/Library/LaunchAgents/
  • /System/Library/LaunchDaemons/

The last two are supposed to be “system only” (only for things bundled with and provided by the OS), but I have seen third-party software put items under /System/Library/.

  • Thank-you! It turned out that there a .launch file remaining in /Library/LaunchAgents/. – Jason Groman Mar 22 '11 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.