I've got a directory called pdfs that contains a bunch of sub- and sub-sub-directories. I want to change ownership on all PDF files in all of the subfolders. I just tried this:

chown -R someuser:somegroup *.pdf

...but it didn't change ownership of the PDFs in subdirectories. The user and group do exist.

According to the man page for chown, the -R should mean recursive:

-R, --recursive
          operate on files and directories recursively

What am I missing?


7 Answers 7


Recursive mode only works on directories, not files. By using the glob '*.pdf' the shell is passing the file list to chown, which sees these are files, and changes the permissions on the files it sees, and that's it.

Remember, in shells, the glob is evaluated by the shell, not the command. If the glob matches files, they are passed to the command and the command never knows a glob existed. (This is different than how Windows Command prompt used to do things). If you have a dir, with the contents something like:

machine:$ ls -F
file1.pdf  file2.pdf  other.txt  subdir/

And you typed:

chown -R someuser:somegroup *.pdf

The shell would first make the list: file1.pdf file2.pdf

and then run your command:

chown -R someuser:somegroup file1.pdf file2.pdf

See, there's no directory for -R to act on. It does what you asked it - change ownership on the two files on the command line, ignoring that quirky -R flag.

To do what you want, to use the '*.pdf' as a pattern for this directory and subdirectories, you can use find, which can find files that match a filename pattern (or many other criterea) and pass to a subcommand

find . -type f -name '*.pdf' | xargs chown someuser:somegroup

This starts in current dir '.' to look for files (filetype f) of name pattern '*.pdf' then passes to xargs, which constructs a command line to chmod. Notice the quotes around the pattern '*.pdf', remember that the shell will create a glob if it can, but you want the pattern passed to find, so you need to quote it.

Because filenames may have spaces in them, you want to use a trick to make it filename-with-spaces safe:

find . -type f -name '*.pdf' -print0 | xargs -0 chown someuser:somegroup

In bash 3 and lower, this is the way you need to do it. More powerful globbing is available in bash 4 (with shopt -s globstar)and other shells. The same in zsh, using a recursive glob **:

chown -R someuser:somegroup ./**/*.pdf
  • 1
    Edited to reflect that bash 4 with shopt -s globstar does recursive globbing.
    – kojiro
    Mar 22, 2011 at 22:54
  • 3
    Per the man page shown by the original poster, I found the chown -R did indeed change owner on folders AND files. No need for find. Using Mint 15.
    – gwideman
    Sep 28, 2013 at 12:23
  • @gwideman I know this is old... But yes, of course -R does recursive. The OP just had an issue with a very specific type of recursion, an extension and "file type is file" filtered one Mar 7, 2015 at 23:40
  • @RichHomolka Ah. OP said the files were in a directory called 'pdfs', so I assumed the problem was in how to specify pdfs as the directory to recurse, and that all contained files were pdfs, so no need to select them specifically. But you may well be right, if the job is to select only pdf files, and leave others unchanged.
    – gwideman
    Mar 8, 2015 at 23:51
chown -R someuser:somegroup /your/folder/here/*

This will apply chown to all files and all subdirectories and sub-subdirectories of the specified folder. Use with care.

  • 2
    Somehow sudo chown -R user ./ worked for me, but sudo chown -R user ./* didn't
    – Slaus
    Jun 4, 2018 at 8:14
  • 2
    I know this is old, but though this answers the headline, does not answer the question. This is actually slightly worse than what OP had already tried. Jul 20, 2018 at 15:29
  • 6
    @RichHomolka Having been brought here just because of the question title, I am quite happy to find this answer. Mar 12, 2019 at 20:49
  • @FélixGagnon-Grenier fair enough. If this answer works for you I’m very happy. But it wouldn’t have worked for the original question. Mar 15, 2019 at 17:22
  • 1
    This worked for my hidden files ("dot files")
    – lobi
    Feb 21, 2020 at 20:46

You can use the find utility:

find . -name '*.pdf' -exec chown someuser:somegroup {} +

Please don't forget the quotes around *.pdf. Otherwise the shell will try to expand it. This means already the shell will replace *.pdf with the names of all PDF files found in the current directory. But that's not what you want. You want to find the PDF files located in subdirectories. Btw.: That's also the problem with your chown command.

  • 1
    I had to look up the +, neat trick for performance. -exec command {} + This variant of the -exec action runs the specified command on the selected files, but the command line is built by appending each selected file name at the end; the total number of invocations of the command will be much less than the number of matched files. The command line is built in much the same way that xargs builds its command lines. Only one instance of {} is allowed within the command. The command is executed in the starting directory.
    – Patrick M
    Jan 13, 2014 at 18:28
  • @PatrickM one (minor) other advantage to + vs ; .... plus isn’t a shell meta character and doesn’t have to be escaped Jul 20, 2018 at 14:36

The command

chown -R someuser:somegroup *.pdf

will only recurse down directories if the directory name ends in .pdf. You need something like:

find . -name "*.pdf" -exec chown someuser:somegroup {} \;
  • Technically it will only go to one level down. whether you call that true recursion or not is an exercise for the user :) Apr 6, 2015 at 21:28

to change the ownership of a directory recursively simply use:

sudo chown -R <username>:<groupname> <dir name>

here username = the new user who should be owner of directory

groupname = the new group which should be owner of directory

every file/directory has a user owner and a group owner

  • This does not do what the OP asked. This changes ownership of everything, OP asked for a specific set of files. Jan 15, 2017 at 18:50

I use tree instead:

 sudo tree -fai ~/.blabla  | xargs -L1 -I{} sudo chown youruser:youruser {}

Also take care to not run recursive chown or chmod on '/' directory or other system directory.


To become the owner of all files in a directory, use

find directory -type f -name '*' | sudo xargs -d '\n' chown $USER

instead of

sudo chown $USER directory\*


sudo chown --recursive $USER directory

which might not work if there are too many arguments produced by * (too many files in the directory) or which does not not do what you want respectively.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .