3

I am using Outlook 2010, but I am unable to find a way to search through all the sub-folders of a shared mailbox. I believe this may be a limitation of the software, but I sincerely hope I am wrong.

5

Open the advanced find (Ctrl+Shift+F) and, using the browse option button, select the shared mailbox and then check the check box below Search subfolders.

enter image description here

  • Do you happen to know if there's any particular reason why that wouldn't work? On mine "Search subfolders" is greyed out. – SilverbackNet Mar 7 '12 at 1:44
  • First though are restrictions applied in Exchange or on the Outlook installation, assuming you're in a work place. But I don't have first hand experience with that issue. – edusysadmin Mar 8 '12 at 1:11
3

http://answers.microsoft.com/en-us/office/forum/office_2010-outlook/unable-to-search-subfolders-outlook-2010/10b8f650-5a78-4bff-b527-3241b2ceb74e?msgId=d8146d4d-88bb-455b-94e1-b468cd70c32f

This solved the problem for me.

Answer 1:

Check if the option to search 'All Mail Items' is enabled.

  1. Click inside the search window.
  2. Once done you would find 'Search Tools' tab appear in the ribbon.
  3. In the search tools tab, enable the option 'All Mail Items'.

Answer 2:

Disable the Download Shared Mailbox in the Advanced Settings of Outlook in Manage Cached Settings.

  • Please don't just provide a link, copy and paste the relevant text from that link into your answer. – Tog Jan 10 '13 at 17:07
2

I had the same problem with outlook 2010, I could search sub-folders with my own account but if I tried to search sub-folders of a shared mailbox it was greyed out, this is what I did to fix it:

File -> Account Settings, choose your own account name
Click Change, More Settings, Advanced Tab, untick Download Shared Folders.

Restart Outlook.

0

It is all terrible and broken (even in the latest Outlook 2016 versions), we have switched to IMAP (in Outlook) for shared mail boxes and use Windows' search indexer to sort it all out. This also provides the added advantage that Outlook will actually set the 'from' address for new emails to the address of whatever mailbox you are currently looking at.

We tried everything else, no other options worked well enough for day-to-day-use.

It is basically a matter of creating a new IMAP account and specifying the address of the shared box as the email address. The only real change compared to adding normal IMAP boxes is to use username\shared-mailbox-name as the login name.

e.g. mylogin@mydomain.com\sharedboxname

enter image description here

Sometimes it is a bit fiddly. In some cases (I could not find a pattern) Outlook removes the \sharedboxname suffix from the User Name, resulting in the mailbox of the main user account being displayed. If that happens, just edit the account settings again and add back the \sharedboxname suffix.

More details in this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.