2

I'm installing Firefox 4 on my work's managed linux system, so I can't access the package manager.

I downloaded the Firefox 4 tar from their website and unpacked it into my home directory as per the instructions given here which say to unpack the tar into ~, which gives the directory ~/firefox.

After doing this run the firefox script as ~/firefox/firefox. When I do this I get the error message:

Couldn't calculate the application directory.

Has anyone else experienced this. It worked ok with the Firefox RC2 that I've just tried replacing.

  • I've got the same problem, but with thunderbird rather than firefox. – Chris Cleeland Apr 27 '11 at 12:55
  • If you are still having this problem, are you running a 32 bit version of linux? If so, is it possible that your home directory is on a filesystem with 64 bit inodes? – Mark Booth Sep 20 '12 at 9:58
1

I was able to solve this problem on Fedora Linux 10 by adding the directory that contains the firefox binary to the PATH environment variable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.