0

I'm running Windows 7 Professional 64-bit on a 64-bit machine. With some applications when I double-click a file in Windows Explorer or open it as an email attachment the application loads, but the file does not load once that application is open. I cannot drag and drop the file from Windows Explorer into the open application either. I am forced to use the File --> Open dialog. I did not have the same problem with these same applications on m Windows XP Professional SP3 32-bit machine.

I have set the EXEs on all of the applications I'm having this problem with to run as administrator and that does not help. It is happening with Visual Stduio 10 and PL/SQL Developer, but it isn't happen with Microsoft Office. Does anyone know how to fix this?

  • Some applications are just not written to take a file input on launch, this is a decision (or oversight) of the developer. I find it odd if Visual Studio isn't...I have no firsthand experience with it, though. – Shinrai Mar 23 '11 at 17:29
  • Visual Studio is able to do this. I can do it on other machines. – Billkamm Mar 23 '11 at 17:50
0

Check the file type association in Folder Options. In the Advanced dialog you should be able to edit the Open action for a particular file type to see what command is being run. It should be something like "C:\full\path\to\program.exe" "%1". Make sure the %1 is present, which is a placeholder for the file path. Make sure the quotes are present around "%1" so that file paths with embedded spaces will work.

If you still have access to the XP machine where it's working, check the file association there as an example of what it should look like on 7.

  • Thanks gordoco. I checked and they are the same on both machines. I think the issue lies elsewhere. – Billkamm Mar 25 '11 at 4:06
0

It sounds like the problem might have been made worse by enabling the "run as administrator" option. When you run a program as a different user in windows the drag and drop file opening functionality doesn't work. It's something to do with the security settings in windows not allowing the inter-process communication necessary to accomplish this. Make sure the user that's running the app is the same one that you're logged in as. To me it sounds like you need to disable that run as admin and then repair the file associations the particular file type(s) that you're trying to open. There are a few tools and sites that can help you with file type association repair. If it's just one or two file types you probably don't want to use any "nuclear options" that restore defaults for all of them, but they're available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.