On just one computer in my household, I cannot complete a successful traceroute nor browse in any browser to a seemingly random-selected, small set of websites. This includes sites like twitter.com to my own site, thislooksnice.com, and have yet to find a rhyme or reason. However, I'm able to ping and get a response from them just fine. On my iPod Touch and other computers, I can browse to the sites just fine.

I'm on a Mac running 10.6.7. I can't think of anything I've changed lately that has anything to do with my DNS/network settings. I normally use OpenDNS. I tried disabling it at the chance using my ISPs default DNS servers would fix things, but alas, it did not.

At a total loss at this point since this is a tough one to Google. Any thoughts?

UPDATE: The error I get when trying to traceroute is as follows:

kevin-macbook-pro:~ Kevin$ traceroute twitter.com
traceroute: Warning: twitter.com has multiple addresses; using
traceroute to twitter.com (, 64 hops max, 52 byte packets
traceroute: sendto: No route to host
 1 traceroute: wrote twitter.com 52 chars, ret=-1
  • If it helps any, I've been unable to connect to the following sites thus far: twitter.com, posterous.com, weather.com (oddly, www.weather.com works though). – Kevin Mar 24 '11 at 15:56

Problem solved! It looks like one of my login items was interfering. I cleared out several applications that I didn't really need to have load at startup, and the issue seems to have cleared up since. Unfortunately, I don't know which application was interfering, and I'm not sure I'll take the time to go back and pinpoint it anytime soon. Have already poured too much time into this. Thanks though to harrymc, mehaase, and Spiff for your help!

| improve this answer | |

PeerGuardian installs itself as a service, so even if the GUI is not running, it still is active and may block some sites.

| improve this answer | |

You might try to flush the DNS cache on the problematic computer.

To flush the DNS cache in Mac OS X Leopard, type in your terminal :

lookupd -flushcache 
| improve this answer | |
  • Thanks for the suggestion. Unfortunately, it seems lookupd has disappeared in Snow Leopard. I tried dscacheutil -flushcache, but still no dice. – Kevin Mar 24 '11 at 14:27
  • I also tried sudo killall -HUP mDNSResponder, and no love from that either. – Kevin Mar 24 '11 at 14:41
  • Then this is not a DNS problem. Have you tried another browser? – harrymc Mar 24 '11 at 15:04
  • Yes, I've tried Safari, Firefox, Chrome, and Opera. All report 'can't connect' errors. I've tried clearing cache, cookies, etc. in all browsers. – Kevin Mar 24 '11 at 15:13
  • Does the problem have any similarity the route problem described here ? – harrymc Mar 24 '11 at 16:14

Ping and http use different protocols, which might explain why one works and the other doesn't. Then again, traceroute uses the same protocol as ping, so I have to say I am totally stumped. Traceroute isn't great for troubleshooting because a lot of big routers between you and your destination won't respond to it, so you just get those * * * responses.

Your DNS is okay. I just looked up twitter.com and found addresses in the same range, so it's not a name problem.

The problem is in your routing configuration. One thing I noticed is that you can't reach posterous.com ( or thislooksnice.com ( which both have the same prefix (184.106.*)

Try running "netstat -rn" and posting the output here.

| improve this answer | |

Some tools in Mac OS X — especially traditional Unix command-line tools — use traditional Unix DNS resolver libraries. Other tools — mainly GUI apps, but some command-line tools too — use library calls that are now routed through mDNSResponder.

Most times DNS seems to work in some places but not in others in Mac OS X, the fault lies with mDNSResponder.

I used to just sudo killall -HUP mDNSResponder, but I've found this isn't always sufficient anymore. Now I...

sudo killall -9 mDNSResponder

...and let launchd relaunch it.

| improve this answer | |

The program that was causing this problem is called PeerGuardian. It comes with an uninstaller. If you run the uninstaller, than the problem will go away. You may have to reboot.

| improve this answer | |

I can confirm that in my case the cause of it all was peerguardian on a Mac. Tried solutionto add the non-resolving address range to a custom list but the application is not working properly (at least on mac) as it would allow a site corresponding to an ip and strangely continue to block subdomains of the same domain/ip. For instance if adding the IP for www.sitetobeallowed.com then that would resolve fine once added, but any subdomain such as subdomain.sitetobeallowed.com will not resolve and report a blank page/error.

I had to install PeerGuardiand and call it the day as I've tried to fix to no avail to be able to continue using the app, but that turned into a losing proposition because I'd have to add too many blocked sites to a custom allow list. Too bad, but at least I will no longer be nuts trying to find WTH is going on and why sites are not resolving.

Hope that helps some of you with the same issue and thanks to user73636 whose tip led me to the solution! Much appreciated :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.