When I start my Windows 7, I get a notification

The system event notification service could not be started....

As a result, I dont have Aero, even though my Windows Experience Index is 3.2.
Aero used to work fine before today and I have not installed any new application. I have checked the event log and it reads:

The System Event Notification Service service terminated with the following error:
Overlapped I/O operation is in progress.

I am not sure what this means.

I have seen the services.msc and everything is fine there. Moreover the startup time has also extended and the Please wait stays for more than a minute. This is a sudden problem as everything used to work fine until today.

For Aero I have tried starting Desktop Window manager (as pointed out by the trouble shooter), but with avail. From what I could understand from the forums, the lack of Aero and increased start-up time comes from a single problem of the System Event Notification Service.

This is a personal Computer and I have no active directories installed.


I have this problem on my machine. It's been this way for a very long time. A temporary solution is to open services.msc, scroll down to the System Event Notification Service, and restart it. Then restart the computer; this usually fixes the problem for a little while. I'm still looking for a better solution.

If anyone has a fix for this problem, I'd love to know about it. My system is clear of malware, and a system restore is not an options since this problem has been in place for so long.

  • 1
    Tried all that bro!But to no avail.As far I could understand it is a hardware issue.Windows 7 waits a short period for your GPU to respond.If it doesn't then it switches to the no -Aero mode.There must be multiple reasons,but I figured out mine.! fine day my GPU started working perfectly and everything is fine now! – user38923 May 26 '11 at 12:46

Check your system for malware first

How can I remove malicious spyware, malware, adware, viruses, trojans or rootkits from my PC?

Then if the system is clean, try a Windows restore point, choose a restore point before the strange behavior started. System restore may not solve the issue if the system is infected by malware.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.