I have a phantom USB memory stick appearing and disappearing repeatedly on my Windows 7 HP laptop computer model 8730w. The computer keeps making a noise 'bah-dum', about once a second and in the 'Memory Stack' briefly (1/8 of a second) appears as F: drive before disappearing.

I've never put a memory stick on this machine since Windows 7 was recently installed. At first this did not happen after install, then it started.

This is causing havoc on my system. Menus that are opened get closed in sync with the beeping, making it hard to use menus if you are not quick enough.

How can I exorcise this phantom drive from my system and reclaim control of my computer?

migrated from serverfault.com Mar 26 '11 at 13:20

This question came from our site for system and network administrators.


enter image description hereOK! So I was incorrect in my post. It happens after a LONG day and a LONGER Night. Fresh eyes the next morning, AND Three Phantom Drives forced me to dig in and SOLVE this issue.

(The above was originally created as a PDF and hosted on a google docs site. I've downloaded the single-page PDF as an image and included it in this response.)

  • That stinks, now thay can't see half of the photos nor download the file... So much for all that time it took to make it. Cheers... – Jim Jones Sep 4 '12 at 17:16

I just had this exact same problem. It is really very annoying to try and troubleshoot this while these windows keep popping up. If anyone has a way to turn these updates off it would be very helpful to anyone else having to deal with this.

I ended up sorting showing hidden devices and sorting by connection as suggested. I found several disconnected F:/ drives listed as a "Portable Device". I went ahead and deleted these.

After a reboot I haven't had the issue, but I will post back after a while to confirm that this fixed it for me.

Edit: It came back, it is a Micro SD slot causing the problem. Instead of deleting it (as suggested below) I just disabled the device. For now I get a sound every so often, but no popup. Will post back here if I find anything else.

  • It's been about a day now, and I haven't had any more issues. My guess is that the Ricoh drive the other person deleted wasn't the root cause of the issue, it might have just been something "attached" to it. Maybe someone with a bit more knowledge could shed some light? – Ethan Feb 18 '12 at 15:31
  • I spoke too soon! Moments after posting the above I started to get the F:/ drive popup again. Going back in and looking at the Disk Drives I noticed the O2Micro xDPicture SCSI Disk Device was causing my problems. I don't have anything plugged into that port, it is probably something that is either stuck in that port causing a short or something in the computer. Instead of deleting the device as suggested before, I just disabled the Disk Drive. Every so often I get a different sound, as if it is trying to connect, but no popup appears. I'll keep digging to see if I can get rid of the sound too. – Ethan Feb 18 '12 at 15:47

Does it always flash in and out? That is, does it never stay long enough to examine the details?

In any case, open a command-prompt and type the following.

set devmgr_show_nonpresent_devices=1

Next, in Device Manager, select View->Show hidden devices, expand the Disk drives branch, and note down the name of the phantom flash-drive.

Now select View->Devices by connection then click My Computer (or whatever name your root device has—pressing Home should also suffice) and press the * key on the numeric-keypad (or in your case, the laptop equivalent).

Then scroll down to your USB devices (it will likely be towards the bottom). Look for the device name that you noted. It should be a leaf-node connected to a USB mass storage device, which in turn is connected to a USB root hub.

Right-click the leaf-node (the one with the drive icon) and select Uninstall. Repeat for the mass-storage device it was connected to.

Optionally reboot (it’s recommended since then you’ll know if it was a software issue or a hardware issue).

  • Yes always flashes in and out. The device manager keeps collapsing all and re-expanding as the device comes in and out, very annoying. Device name is 'Ricoh Memory Stick Disk Drive'. Because of the open close repeatedly, I can't find the item in the view devices mode. – WilliamKF Mar 26 '11 at 17:27
  • That’s why you have to open it with the above environment variable set and select show hidden devices so that you can view devices that are not currently connected to the system. That way you should be able to see it and uninstall it regardless of if the system thinks it’s there or not. Did you do both parts? – Synetech Mar 26 '11 at 17:42
  • Exactly as described, but it refreshes continually making it really hard to do anything. – WilliamKF Mar 26 '11 at 17:58
  • I managed to find it listed under Microsoft ACPI-Compliant System -> PCI bus -> Inter(R) 82801 PCI Bridge - 2448 -> Ricoh Memory Stick Controller -> Ricoh Memory Stick Disk Device. Once uninstalled, the flickering ceases! I also uninstalled the parent node, Ricoh Memory Stick Controller. – WilliamKF Mar 26 '11 at 18:05
  • Reboot and it first hung with "_" in upper left corner of black screen, tried again and it blue screened at login with DRIVER_IRQL_NOT_LESS_OR_EQUAL STOP 0xD1 CipcCdp.sys, tried again and I login fine, but the Ricoh device is back and beeping again, I uninstall it again and it gets errors and beeping only goes away this time when outer one is uninstalled (not the leaf). – WilliamKF Mar 26 '11 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.