2

I've been using a good old powerbook (g3, bronze keyboard) with Debian Linux for years now. Woody (3.1) was still hard to install because of keyboard issues. Etch (4.0) and Lenny (5.0) were very easy to install and use.

I recently tried Debian squeeze (6.0) which works fine if I don't install any xorg / window manager components (text console only). Once the machine tries to load X, I run into trouble, likely with the graphics card driver, and the machine hangs with just a thin, horizontal line of garbage approx. 3/4 down the screen. Jumping to the text consoles (F1...F6) is no option, the only thing that works at this point is the the power button for shutting it down.

I've fixed a similar problem with "vga=791" in the grub boot options on i386 notebooks, but what do I do about this on the PowerBook?

  • +1 I'm another Powerbook g3 user (wallstreet)! I use Ubuntu 10.4 happily :) – Pitto Mar 27 '11 at 11:22
  • Was X running fine on those earlier Debian releases? – tshepang Mar 27 '11 at 17:49
  • @Tshepang: Yes, X was running fine with no trouble at all on 3.1 thru 5.0. – zebonaut Mar 27 '11 at 18:03
  • Have a look here, and then uninstall the relevant xsever-xorg-video-<driver>, then restart X to see if it works fine. By doing that, it should fall back to the generic driver (xserver-xorg-video-vesa), which should work ok. – tshepang Mar 27 '11 at 19:18
1

I would download the proper xorg.conf file for that PowerBook. You can find many of those on: http://mac.linux.be/content/xorgconf-files

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.