I have a WD My Passport external drive which used to work fine on my Win7 x64 box until recently. Since the past few days, windows would not detect my external drive. However, Storage under disk management lists my external drive(which means windows can see my drive) but without a drive letter. I am not able to assign a drive letter(the option is grayed out). I installed EASUS Partition Manager which allows me to assign a drive letter, but fails to do so when I apply to save changes. What do i do to assign a drive letter to the drive or make windows to detect it as of old? The external drive works well on Win7 x32(dual boot, same system) and win7 x64 on another box. Update: cant comment from Opera Mini 6 @zeke the drive works absolutely fine on other Win7 boxes and on the dual boot win7 on the same system.

  • Can I assume that there is no problem with the file system on the disk? And that you can mount this drive other places and are able to ready it? Mounting a foreign file system (such as might be used for a Mac or for Linux) will result in the hardware being recognized but no drive letter. But I've had situations with an NTFS file system not cleanly unmounted elsewhere needed attention if I try to mount it under Win 7. – Zeke Hansell Mar 27 '11 at 20:17
  • just curious, if you go to device manager, right click the drive, do properties, go to volumes tab... click populate... does it fill in the blanks and/or give it a letter? – CreeDorofl Mar 27 '11 at 20:45
  • Can I assume that you haven't run out of drive letters? (Sounds crazy, but I have... And, sadly, it doesn't roll over to AA:, AB:..) – skub Mar 27 '11 at 20:48
  • @skub I am at J.Still have a long way to go. – abel Mar 29 '11 at 11:05
  • @CreeDorofl I got the Disk Management Console view is not up-to-date error, however I've solved the problem – abel Mar 29 '11 at 11:06

I had already tried uninstalling the WD drive and removing the drivers from Device Manager, however, reattaching the drive resulted in the drive being installed but not displayed. Then I noticed an entry in Device Manager>Storage Devices> called "Unknown Device". The device did not have an exclamatory sign or cross sign to indicate problems with the device. I uninstalled it, uninstalled the WD SES entry from Device Manager and rescanned for hardware changes. Windows detected my drive and Autoplay popped up prompting to play videos or open folder to view the drive.

The Device Manager does not have the Unknown device listed now.

I also installed USBDLM, which showed a balloon tip telling me that the drive had been assigned the letter J. I don't think using USBDLM was necessary in this case, but I haven't verified otherwise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.