5

Any attempt to save emails in Thunderbird produces the "Unable to save your message as draft" message box, and sending fails similarly with "Sending of message failed".

(I've checked the obvious. Folders were all compacted/repaired recently. There is no actual flaw in the profile email settings, and the problem persists in a new profile.)

Specifics:

  • OS is Win XP Home.
  • The problem does not occur for other Thunderbird users with logins on the same machine; it is specific to this user.
  • The problem does occur even in a new, blank Thunderbird profile created for this user.

I assumed it was a file corruption issue in the profile, but it can't be if it happens in a new profile. Does anyone have any debug suggestions?

Update: Solution

Problem solved; ChrisF was on the right track. The Windows Temp directory environment variable for the user identity had been changed to a nonexistant path, so Thunderbird couldn't create temp files. Correcting this solved the problem.

0
1

Does that user have write rights to the files and folders where Thunderbird is storing the e-mails?

2
  • Yes. (They're in the usual Thunderbird XP default location: \Documents and Settings\<username>\Application Data\Thunderbird\Profiles). File read/write from that user ID works normally. User ID has admin access. (Email is received and saved normally, just not sent.) – Tynam Mar 30 '11 at 12:56
  • Update: Problem solved. You were on the right lines and gave me the idea to check, so I'm accepting this answer. – Tynam Mar 31 '11 at 8:47
1

Two things can fix these problems:

  1. Go to extra > settings, click on advanced, go to sub-tab "network and diskspace" and check if the last option to merge folders if bigger than 20MB is enabled

  2. Login to the computer-user-account with the problem, right-click the shortcut to Thunderbird, hit properties (depending on your system language), go to compatibility and check "run this program as an administrator" and hit the button "change settings for all users" to quit reproducing this problem on new accounts. Hit OK and start the program. You'll be prompted for an admin password. Fill it out and hit "remember".

0

At my PC deleting MOZ_MAPI didn't help. But by coincidence I discovered that unchecking

in Enigmail-menu item "Protocol: Inline PGP" (save doesn't work) into "Protocol: PGP/MIME" (save works)

solved the problem here. At my PC this can be reproduced at any time now.

0

Here's the only solution to this problem:

I've encountered the same case with Thunderbird, it would not save to Draft folder by no means. I've tried many options: such as changing the mailbox settings, changing IMAP etc. The only remedy that was out there is: - Write down settings information of given mailbox, - Remove that mailbox completely - Create a new mailbox, put all the IMAP/SMTP info in there again - Wait until Thunderbird uploads all the Inbox, Draft, Send, Bulk, Trash folders e-mails again. - Saving to any folder should be working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.