I have a bizarre issue going on with my Ubuntu installation. Yes I have read and followed the instructions for this post and the answer doesn't work (as I'll explain in a moment) for me!

I'm not sure exactly when this began happening, perhaps after I ran an update, but Flash has simply stopped working altogether on my machine! And every solution I've found so far has proven to be ineffective. If I go to, say, youtube, and click a movie to watch, I just get a black screen. Same for ebaumsworld, or any other Flash media site. Just a black box.

I went to Ubuntu Software Center, typed in Adobe Flash Plugin, and got to the box where it says Use This Source. Clicking on it just makes my whole machine freeze, and I never end up getting to the section where you can click the Install button!

When I go to Adobe Flash's site, which automatically detected what version (if any) of Flash you have, it just freezes the browser and I have to kill the process!

I have even used Ubuntu Software Center to uninstall, and subsequently, re-install Flash, and get the same thing every time.

Any ideas or suggestions!?! I can't live without me flash!

Edit: It seems that my machine is attempting to read the SWF with something called Gnash. I was thinking that maybe, when I ran an update, I downloaded this Gnash and it set itself up as the default SWF player. If something is wrong with it, then that would explain why I suddenly lost the capability to play SWFs: I'm not using Adobe Flash anymore, instead I'm using Gnash. Thoughts?

  • 1
    I suspect you're running 64bit?
    – n0pe
    Apr 1 '11 at 18:15

If you are using 64 bit ubuntu, try following the guide here : http://nxadm.wordpress.com/2009/04/26/install-64-bit-adobe-flash-player-on-ubuntu-904/

If not, have you tried installing the flash plugin from the terminal ? Try running this from the terminal (you need to enable Canonical Partner sources from synaptic > settings > repositories > other software > Canonical partners for this):

sudo apt-get update    
sudo apt-get install adobe-flashplugin

and also i would recommend uninstalling gnash in this case using

sudo apt-get remove gnash
sudo apt-get autoremove
  • Gnash was being crap for me on 32 bit (slow processor). I did this, but I had to re-install adobe-flashplugin after removing gnash. Actually, just running update-alternatives probably would have done it too.
    – naught101
    Mar 1 '12 at 5:08

It seems that some of the latest versions of Flash are incompatible with old computer hardware.

I also had the problem of Flash no longer working after an update. If you want to continue using the same computer you will need to install an old version of flash, say from late 2010.

You simply copy the libflashplayer.so file to /usr/lib/adobe-flashplugin. You will probably need to do this from a terminal using the sudo cp command.

For example:

sudo cp /home/user/temp/libflashplayer.so /usr/lib/adobe-flashplugin

This fixed the problem in my case but only for Firefox, not for Chrome. Also make sure that you stop updating the Flash player. Archived versions of Flash are available from the Adobe website.

  • Chrome bundles its own version of Flash, that's why.
    – slhck
    May 4 '12 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.