Browser - Chrome (latest version - 10.0.648.204)

On http://www.youtube.com, the player never displays - the whole Flash area (including where controls should be at the bottom) is just black. Strangely, the exact same videos embedded into other sites work fine, as they do when changing the URL to https://www.youtube.com.

I've tried clearing all YouTube cookies; and even clearing Windows 7 Basic internet cache, uninstalling Flash entirely (in case it's interfering with the internal implementation in Chrome), disabling Flash hardware acceleration.

As I have a workaround it's not essential, but it'd be an interesting one to pinpoint - any ideas? (Would obviously prefer not to delete all my cookies, sign-in data etc for no reason!).

Edit (10th Apr 2011) - ok, so it's now working again, somehow(!). Apologies that I wasn't able to pinpoint what changed, but I'll keep an eye on this post, and definitely let everyone know if it happens again...


I had very similar symptoms under Mac OS X shortly after upgrading the Flash 10.2. For me, Several, but not all, Flash video sites were affected, not just YouTube. For me, none of the following helped:

  • Upgrading to the latest minor rev of Flash.
  • Downgrading to Flash 10.1 (still available for free download on a developer-oriented section of the Adobe website for the sake of backward-compatibility testing)
  • Enabling or disabling hardware acceleration
  • Changing browser settings
  • Changing Flash settings
  • Disabling browser extensions
  • Disabling browser plug-ins besides Flash
  • Deleting Flash-related browser cookies
  • Using a different browser (Safari, Firefox, Chrome)
  • Restarting browsers several times throughout this process
  • Logging out and logging back into my account
  • Restarting my machine

Eventually I created a new user account on my system and it seemed to work from there. So I went back to my main account and fixed it by deleting all of my Flash preferences / Flash-style cookies / Flash local storage, including:

rm -rf ~/Library/Preferences/Macromedia

...and then restarting my browser.

To do: Can users of other OSes update this Answer for where to find (and how to delete) these same kind of Flash preferences/cache/cookie files under those OSes? I'm marking it as a Community Wiki to make it easier for others to edit.

  • Trashing ~/Library/Preferences/Macromedia seemed to fix this problem for me (in Chrome v20'ish, Flash v11.3'ish) – dbr Jul 16 '12 at 13:55

I went here and deleted everything on all browsers and it worked for me hope it works for you!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.